Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
CaseyB
Collaborator

Object Explorer - Unused Objects

Hello all, couple questions on unused objects. Management server is an Open server on R81.10 Take 87.

 

  • I noticed the following objects in our environment are not included in the "unused objects" filter within object explorer:
    • Domains
    • Interoperable Devices
    • VPN Communities

Coming into a new environment, this makes cleanup of the management server a little more cumbersome, but I am working through it. There might be other objects as well, but these are the ones I have noticed so far. Is there a particular reason these are not listed?

  • If a "Network Group" is listed as "unused" and you delete it, does it just delete the group or does it delete the group and all the objects within it?

Thank you!

0 Kudos
7 Replies
the_rock
Legend
Legend

It would delete whatever is within it as well. I agree with you that it does make cleanup little more time consuming, since not everything is inclluded in object explorer, but if you think about it, its not such a terrible thing, as when it comes to domains/vpns, better to be 100% sure : - )

0 Kudos
PhoneBoy
Admin
Admin

Where Used only shows objects not explicitly used in the Access Policy.
VPN specific objects do not need to be in the access policy to be used, thus “where used” would not return accurate results in this case.

As far as I know, deleting a group should not also delete the objects therein.
However, thanks to database revisions in current versions, even if it did, you could undo by reverting to a prior version.

0 Kudos
the_rock
Legend
Legend

Interesting...couple of times I deleted the group, it also deleted what was inside of it too. I was a bit surprised at that, but was able to bring them back by revision.

0 Kudos
CaseyB
Collaborator

I tested this morning and only the group was deleted, the objects within the group remained intact.

(1)
the_rock
Legend
Legend

Thats good. I verified the same in R81.20 and also in my old R81.10 lab. Last time it deleted everything inside the group was in R80.40, thats why I mentioned to phoneboy I was bit surprised at that, but had not happened since.

0 Kudos
Nik_Bloemers
Advisor

Domain objects not working in Unused Objects is a big miss for me too.

the_rock
Legend
Legend

Hopefully it gets improved with future releases, lets see.

0 Kudos

Leaderboard

Epsum factorial non deposit quid pro quo hic escorol.

Upcoming Events

    CheckMates Events