Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Mark_Edwards
Explorer

SmartMove Juniper Unspecified SRX version issue

Hi, 

get the following error/issue when trying to use SmartMove for a Juniper 12.3X48 configuration. 

 

Unspecified SRX version

Cannot find SRX version for the selected configuration.

The configuration might not parse correctly.

 

I can see the following in the Juniper xml file so it seems that the version is there unless wrong format, etc.   

<rpc-reply xmlns:junos="http://xml.juniper.net/junos/12.3X48/junos">
<configuration junos:commit-seconds="1617108612" junos:commit-localtime="2021-03-30 14:50:12 WAST" junos:commit-user="Ndapanda">
<logical-systems>
<name>OPM_OUTER</name>

Anybody have a sample Juniper xml file that does work so I can compare?

Thanks.  

 

0 Kudos
4 Replies
_Val_
Admin
Admin

Make sure you are using the latest SmartMove version. If this is the case, and it is still failing, please open a support call with TAC

Ofir_Shikolski
Employee
Employee

The format should as:

<rpc-reply xmlns:junos="http://xml.juniper.net/junos/12.3X48/junos">
<configuration junos:commit-seconds="1599185114" junos:commit-localtime="2020-09-03 22:05:14 EDT" junos:commit-user="root">
<version>12.3X48-D45.6</version>

the_rock
Mentor
Mentor

I used smartmove with Cisco and it always worked. Cant really comment for Juniper, as I am not familiar much with it, but comments guys made make logical sense to me.

0 Kudos
Mark_Edwards
Explorer

Hi, thanks for the feedback.

Using the latest version.

Issue must be with the xml output generated.

The version info was missing 

0 Kudos