Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Maller
Contributor

vsx upgrade with non-DMI

Hello I tried to do a CPuse upgrade of a VSX cluster but I got this message after installer verify : "Result: R80.40 Gaia Fresh Install and upgrade Clean Install: Installation is allowed. Upgrade: Upgrade a VSX with Non-DMI configuration is not supported." As I understand , now I'm forced to do a clean install on these gateways but I've some questions , after "upgrade clean install" - snapshots will survive , right? - At the end of process , some configuration remains in gw ? - If so , this remaining config can cause issues when vsx_util reconfigure ? It should be removed? - Is there some documentation with samples using vsx_util reconfigure command? thanks
0 Kudos
4 Replies
Bob_Zimmerman
Advisor

Snapshots survive an 'installer clean-install <whatever>', because that does not affect the filesystem on the storage. Snapshots do not survive a real clean install with ISOmorphic.

My understanding is 'installer clean-install <whatever>' only leaves the IP address and mask of whichever interface you have selected as the management interface, and maybe the password of the user 'admin'. I don't personally trust anything but a real clean install for VSX upgrades, but 'installer clean-install' is probably fine. Just remember to build your bonds before you try to reconfigure.

Maller
Contributor

Hi 

Let me ask you this question.... this non-dmi vsx deployment is being managed via  VSW through a WRP0 interface

When gw is  clean install upgraded , Will I be able to configure by console this interface and assign ip to be managed?  

 

thanks

0 Kudos
Bob_Zimmerman
Advisor

How in the world did you manage to build that? I don't know of any way to have a wrp interface before you have SIC with the management server.

0 Kudos
Maller
Contributor

yes , that's my doubt.  This VSX is managed  by MDS via  wrp interface  . In a clean install upgraded gateway , which interface should be configured in order to communicate with MDS  before  to execute vsx_util reconfigure? 

I don't see this step and I have no lab to test it......

0 Kudos