Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Flanger
Participant

ClusterXL standby member does not install OSPF routes

Hello,

We're running four R80.30 Security Gateways (hotfix take 219) with two of them being in HA ClusterXL mode. Topology is fairly simple:

topo.JPG

FW1 and FW2 have OSPF adjacencies formed between each other and cluster VIP (10.20.100.63), everything works correctly there. Cluster members, both show OSPF adjacencies formed with FW1/FW2 and both have OSPF databases populated, but only the active member installs routes in the routing table. The problem occurs when failover happens. After standby member becomes active, the routes are still not being installed and effectively all the traffic stops. This persists until I manually restart routed.

When first member comes back online and stays as standby (we do not have preempting configured), it exhibits the same behavior. Adjacencies are formed, OSPF database is populated but routes are not installed.

Is there anything I'm missing in configuration?

0 Kudos
Reply
5 Replies
John_Fleming
Advisor

Do both members have the same router-id? Is the cluster health before the failover? Do the routes show up as hidden by chance? (show route all)

from clish enable ospf tracing and look in /var/log/routed.log

set trace ospf all all on

set trace global all all on

set trace kernel all all on

Something like that.

0 Kudos
Reply
Flanger
Participant

Members have unique OSPF router IDs and routes do not show as hidden either. They are just absent, only present in OSPF database. There is no other problem with the cluster, I did manual failover to test it using clusterxl admin down/up on active member first and then tried again by reloading active member, I thought it's expected behavior and routes will install once standby becomes active. That didn't happen. Interestingly after I reloaded routed, traffic started flowing but routes would still not show up for another minute or so.

0 Kudos
Reply
John_Fleming
Advisor

The members should have the same router-id. That might be the problem.

0 Kudos
Reply
Flanger
Participant

Thanks for the tip. I will make changes within next downtime window and reply with the results.

0 Kudos
Reply
John_Fleming
Advisor

FYI  - I don't remember if this is the case, but I think it will not let you change the router-id without first removing the OSPF config. PITA I know. 

0 Kudos
Reply