Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
dumbhead123
Contributor

PHP version update

Jump to solution

Our internal vulnerability tools have identified this firewall as having an out of date PHP version 5.6.11 installed.


This is currently installed with R80.20 take 141. What version of Gaia OS needs to be installed to update to the latest version 7.4 or 8.0

observed  php -version 7.2.13 (cli) with version R80.40. 

 

0 Kudos
1 Solution

Accepted Solutions
PhoneBoy
Admin
Admin

Just because it’s an older version doesn’t mean it hasn’t been patched against known vulnerabilities and/or those vulnerabilities are even relevant depending on how precisely we use it.

View solution in original post

0 Kudos
3 Replies
G_W_Albrecht
Legend
Legend

Do you see any real need to update to the latest version 7.4 or 8.0 ? As you need expert access to the GW for executing PHP commands i see no danger here...

But upgrading to R80.40 is strongly suggested!

0 Kudos
PhoneBoy
Admin
Admin

Just because it’s an older version doesn’t mean it hasn’t been patched against known vulnerabilities and/or those vulnerabilities are even relevant depending on how precisely we use it.

View solution in original post

0 Kudos
dumbhead123
Contributor

Thanks for the information. observed php -version 7.2.13 with version R81 as well.

0 Kudos