AnsweredAssumed Answered

always returns empty search result while using filter option of "show-access-rulebase" API for domain with global policy(provider1)

Question asked by Ekta Siwani on Nov 16, 2017
Latest reply on Dec 26, 2017 by Ekta Siwani

Hi,

 

I have a domain with global policy installed (provider 1).

To login I used following syntax:

{

"user" : "username",
"password" : "password",

"domain" : "domain name"

}

 

I am using "show-access-rulebase" API with filter option (packet mode), but it always returns null.

{
"offset" : 0,
"limit" : 20,
"name" : "uid of layer",
"details-level" : "standard",
"filter-settings" : {"search-mode":"packet"},
"filter": "23.23.23.23"

}

 

When I tried same from smart console I am getting the correct search result.

Tried the same API on a domain without global policy installed, search result returned is correct.

 

Outcomes