Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
BlueGrass
Contributor

"auto-negotiation on speed" and "link-speed" are different

Dear All,

 

My 1G ISP is connected to eth1.

Then we find the speed test result is slow.

The show interfaces all Appears below result:

 

Interface eth1
state on
mac-addr XXXXXX
type ethernet
link-state link up
mtu 1500
auto-negotiation on
speed 1000M
ipv6-autoconfig Not configured
duplex full
monitor-mode off
link-speed 100M/full
comments Sonicwallx1_Wan
ipv4-address XXXXXX
ipv6-address Not Configured
ipv6-local-link-address Not Configured

 

Why this is happening with both speeds different?

4 Replies
Timothy_Hall
Champion
Champion

The firewall interface is Gigabit capable and set by default to operate at 1000Mbps, but cannot go faster than 100Mbps.  This could be because the ISP router is only set to run at 100Mbps, or you are using a Cat3 cable instead of a Cat5e or Cat6 cable; Cat3 can only link at 100Mbps.

Run command netstat -ni, if you are taking RX-ERRs you almost certainly have a duplex mismatch with your ISP running at 100/half and your firewall running at 100/full.  Assuming you are supposed to be running at only 100Mbps due to your agreement with the ISP, tell the ISP to hardcode to 100/full and hardcode your firewall interface to 100/full as well.  Duplex negotiation is more or less broken in Fast Ethernet (100Mbps) but was thankfully fixed with Gigabit Ethernet.

"Max Capture: Know Your Packets" Video Series
now available at http://www.maxpowerfirewalls.com
0 Kudos
BlueGrass
Contributor

Well, I check it out and only no more than 10 in either RX/TX Error/Drop.

Interestingly, the speed test results sometimes reach 3XX Mbps.
xsxso
Employee
Employee

@Timothy_Hall  -=- so you're saying link-speed represents the current speed of the interface vs speed which represents its potential? if so, then what do we make of a scenario where link-speed reads not configured?

Timothy_Hall
Champion
Champion

speed indicates the maximum speed, which the interface will automatically default to unless it has been hardcoded and assuming the attached switchport supports it.  If link-speed says "not configured" then it is set to auto, if anything else appears there the interface has been hardcoded to that speed, or the switchport only supports a lower speed than the interface's maximum speed.  It might be helpful to look at the output of ethtool (interface) from expert mode which also shows the NIC's available link speeds:

[Expert@A-GW-01:0]# ethtool eth0
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 1000baseT/Full
10000baseT/Full
Supports auto-negotiation: No
Advertised link modes: Not reported
Advertised auto-negotiation: No
Speed: 10000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: off
Supports Wake-on: uag
Wake-on: d
Link detected: yes

"Max Capture: Know Your Packets" Video Series
now available at http://www.maxpowerfirewalls.com
0 Kudos