Create a Post
Showing results for 
Search instead for 
Did you mean: 

Site to Site VPN Connection with NAT

Hello everybody!
Sorry if I posted in the wrong place, if I did, can you move my topic to the correct place?
I have a 3600 checkpoint with R81.10 take 335 standalone deployment.
I'm closing a Site to Site VPN with a company.
All networks that I have local were already being used on the company network that I want to close VPN.
So it was necessary to do a NAT, but I never did a NAT this way.
I tried to read the documentation but I couldn't find where I'm wrong.

The topology is as follows.

My business:

Company X:
Host IP:
Host IP:
Host IP:

I created the NAT rule

Original source: a specific host to test the connection.
Original destination:
Original services: any
Translated Source:
Translated Destionation: Original
Translated Services: Original

I created the network rule.

Source:,,, and
Destination:,,, and
Services & applications: any
Action: Accept
Track: Log

The client informs that the traffic arrives at his firewall, but it arrives with my company's public IP, the right thing would be to arrive with the NAT IP, so the firewall drops the packets

Sorry for my english, I'm using google translator

Message in log: Connection terminated before the Security Gateway was able to make a decision: Insufficient data passed.
To learn more see sk113479.


If you can answer this conversation with a print of how to configure it, I would greatly appreciate it


0 Kudos
4 Replies

First thing that came to my mind is make sure inside VPN community that nat is not disabled, its option somewhere on the bottom left, under advanced I believe.

0 Kudos

have you defined the source and destination networks (VPN Domain) in your VPN:Community_to_company_x ?

0 Kudos

I would suggest to involve TAC to resolve this...

CCSE CCTE SMB Specialist
0 Kudos


I use to go through the following step in situations like yours. First check on your logs if the traffic from to destination is being NATed correctly, maybe a higher NAT rule is causing some problem. 

If NAT is OK, make sure that you have real IP's and NATed IP's in your local encryption domain, you should have both. If you have it in this way you can go to the third step.

Go to sk108600:

First check scenario 3, the external interfaces of the Gateway are included implicitly on the encryption. So you have to exclude your external IP address manually editing the crypt.def file according to the sk.

If that don't work you can also try the scenario 1, where you will define your local encryption domain for that peer manually editing the user.def.FW1, i've had cases like yours that were solved with this change and not with the previous.


0 Kudos