Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
S_E_
Advisor

How to identify transceiver / SFP+ adapter?

Hi,

I'm looking for a command to identify if a SFP+ adapter has been inserted and if, which one.
E.g. 5xxx / 15xxx series appliance.

The "show asset all" does not really help
Number of line cards: 1
Line card 1 type: 2 ports 10GbE SFP+ Rev 2.0

Something like this (guess the vendor) would be great
"show interface ethernet 1/1 transceiver"

dmesg command does not really help either.

any ideas?

Regards,
0 Kudos
16 Replies
G_W_Albrecht
Legend
Legend

Maybe sk68780 How to check which driver should be loaded for installed NIC and if that driver will support the installed NIC will help ?

0 Kudos
S_E_
Advisor

hi,

not really. I see a lot of 'should' in the SK.

Somehow, it looks nearyl impossible to identify if

- a CheckPoint SFP+ adapter has been inserted or a noname Transceiver

- if a LR or SR has been inserted

- if anything is inserted.

Thanks

Cheers,

0 Kudos
PhoneBoy
Admin
Admin

The system will not allow installation of a non-Check Point transceiver.

That said, I don't believe the system is able to show further information. 

Tomas_Vobruba
Employee
Employee

Hi all,

 

anyhow you can check status of SFP+ module inserted into the machine with ethtool:

 

[Expert@gw-596d14:0]# ethtool -m eth2
Identifier : 0x03 (SFP)
Extended identifier : 0x04 (GBIC/SFP defined by 2-wire interface ID)
Connector : 0x07 (LC)
Transceiver codes : 0x10 0x00 0x00 0x01 0x00 0x00 0x00 0x00
Transceiver type : 10G Ethernet: 10G Base-SR
Transceiver type : Ethernet: 1000BASE-SX

 

and much more.

Also asi Daemon wrote, only CP SPF modulea are supported..

 

Tomas

 

 

 

0 Kudos
binelipetrov
Explorer

Hi!

 

Is there az other way to see this?

There is no -m switch for ethtool command in Expert mode, for my 5100 model

 

Thank you

 

Vladimir

0 Kudos
Daniel_
Collaborator


@binelipetrov wrote:

There is no -m switch for ethtool command in Expert mode, for my 5100 model

Same here. Looks like it just available in R80.30.

0 Kudos
Daniel_
Collaborator


@Daniel_ wrote:

@binelipetrov wrote:

There is no -m switch for ethtool command in Expert mode, for my 5100 model

Same here. Looks like it just available in R80.30.


Also not available in R80.30 (take136) 🤔

0 Kudos
Timothy_Hall
Champion
Champion

Gaia 3.10 is required to use the -m option for ethtool, the Check Point code level is not directly relevant.

"Max Capture: Know Your Packets" Video Series
now available at http://www.maxpowerfirewalls.com
0 Kudos
Julian_Sanchez
Collaborator

Hi, 

This command dont work for R80.10. Another way for know it? My apliances are 15600

Regards, 

Julian

0 Kudos
Anthony_Kahwati
Collaborator

Was there a resolution found for this by the way I am on 80.20 and cant use the -m switch for ethtool either.

Tomas_Vobruba
Employee
Employee

you have to have 3.10 kernel and new gaia. 

0 Kudos
Anthony_Kahwati
Collaborator

OK, and there is no other way to determine the transceiver type besides physical inspection for any of the OS mentioned in this thread then I guess?

0 Kudos
Timothy_Hall
Champion
Champion

You can try mii-diag as mentioned in this thread:

Is there any way to check fiber interface status?

I suppose you could try bringing over the ethtool binary from a Gaia 3.10 system and running it on a Gaia 2.6.18 system with the -m option, but that is not likely to work and is most definitely not supported.

"Max Capture: Know Your Packets" Video Series
now available at http://www.maxpowerfirewalls.com
0 Kudos
Norbert_Anderss
Explorer

It seems that i have similiar problem.

I'm using Checkpoint appliance 5100 and Checkpoint SFP+ adapter.
Checkpoint verion is R80.40 and Gaia kernel version 3.10.0-957.21.3cpx86_64.
I've run the command:
ethtool -m eth1-01
and getting:
Cannot get module EEPROM information: Operation not supported

It's very strange that it's so difficult on a Checkpoint appliance to see what SFP is inserted. It's a standard information which is avaiable on other vendors appliances, routers or switches.

Do any of you have any other ideas?
All hints are appreciated.

0 Kudos
Timothy_Hall
Champion
Champion

Are you sure you have the right interface (eth1-01)?  That is the error that ethtool -m will return if you target a non-fiber/non-SFP interface.

If it is the right interface, what driver name and version does ethtool -i eth1-01 show?  It is possible the underlying NIC driver simply does not support that operation, or ethtool itself does not know where to find that info for that particular driver.

If it is the latter cause, you can try manually reading the various files under /sys/class/net/eth1-01, one of them might contain the SFP information you seek.  

"Max Capture: Know Your Packets" Video Series
now available at http://www.maxpowerfirewalls.com
0 Kudos
Norbert_Anderss
Explorer

This is the right interface.
driver: igb
version: 5.3.5.18

I can see a lot of files under /sys/class/net/eth1-01 but they are empty.

😞

0 Kudos