Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
gcarella
Explorer

How to edit hosts file on Quantum Spark 1590 Appliance

Jump to solution

Hi all,

 

I have a simple question to ask to the community. How I can set permanently an entry on the hosts file of the firewall?

My setup is a 1590 Quantum Spark appliance running R80.20.25.

I need to resolve a specific FQDN into a specific IP and not using public DNS servers.

There is no way to do this from GUI, also clish commands are not working or accepted.

So I've tried to edit /etc/hosts file in expert mode, but any change is overwritten automatically after some time. When I write inside /etc/hosts file an entry, this works only for some time. After a while it's overwritten and deleted reverting back the file to default.

 

Any idea?

 

Thank you,

Gianluigi Carella

 

0 Kudos
1 Solution

Accepted Solutions
Tom_Hinoue
Advisor

Do you have [Enable DNS Proxy] and [Resolve Network Objects] checked in global DNS settings?

Also not to forget to check [Allow DNS server to resolve this object name] on your network object, and it should work.

netobj_dns.png

View solution in original post

6 Replies
PhoneBoy
Admin
Admin

Editing certain underlying Unix files like that is not supported.
You need to create a specific object for that FQDN either in the WebUI or via the add host CLI command.

0 Kudos
gcarella
Explorer

OK but I've tried using a network object and it doesn't work.

When I try to ping the FQDN the IP is resolved with the public IP and not the private one that I have explicitly configured in the network object.

 

What I'm doing wrong?

 

Thanks.

 

0 Kudos
PhoneBoy
Admin
Admin

Is an entry being created in the /etc/hosts file when you create the object?
It is for me when I do it on R80.20.30 firmware anyway.

13D8F8A0-7081-4560-97E8-11CC75C91D78.jpeg

0 Kudos
gcarella
Explorer

tried many times, but /etc/hosts doesn't reflect what I've configured as network object.

0 Kudos
Tom_Hinoue
Advisor

Do you have [Enable DNS Proxy] and [Resolve Network Objects] checked in global DNS settings?

Also not to forget to check [Allow DNS server to resolve this object name] on your network object, and it should work.

netobj_dns.png

View solution in original post

gcarella
Explorer

Yeah. This works for me. The solution was for all this time under my eyes.

0 Kudos