Create a Post
Showing results for 
Search instead for 
Did you mean: 

mds_setup fails to create a configuration export file for Primary MDS

Hi! All,

Am facing an issue with generating the Primary MDS configuration export file using mds_setup utility (from R77.20 to R77.30 using R77.30 migration tools) . It's taking me around 5 Hours to finish and with an error message stating:




Creating final export file /var/log/exported_mds.7jun2018.tgz

Error: Error creating file

Cleaning temporary workspace /var/log/temp_worksapce

Failed to export Multi-Domain Server Database

A log file was created: /opt/CPInstLog/mds_setup_06_07_22_41.log


If i try to open the log file created i can able to see the below message only:
starting session at Thu Jun  7 22:41:07 SGT 2018
Removing execution permissions of /opt/CPmds-R77/scripts/mdsstart
Removing execution permissions of /opt/CPmds-R77/scripts/mdsstart_customer
Checking for installed components. This may take a few seconds.
Please wait...
mds_setup has detected that your system has:
Multi-Domain Security Management R77.20 installed
Please choose one of the following:
(1) Remove current installation and reinstall
(2) Backup current Multi-Domain Server
(3) Export current Multi-Domain Server
    Or 'Q' to quit.
Please enter your choice:
Warning: If current export is used by cma_restore, refer to sk95227 for further instructions.
*** Proceeding with the export ...
Please download the appropriate migrate tools for Linux from the Support Center.
Navigate to the Multi-Domain Management/Provider-1 page,
choose the Downloads tab, and select the version to which you will import.
Enter location of downloaded file (or q to quit):
Failed to export Multi-Domain Server database
A log file was created: /opt/CPInstLog/mds_setup_06_07_22_41.log
ExitTrap> Restoring execution permissions of /opt/CPmds-R77/scripts/mdsstart
ExitTrap> Restoring execution permissions of /opt/CPmds-R77/scripts/mdsstart_customer

I don't think this issue is because of free space concern, as i have root and /var/log/ partition with 100GB & 180 GB free space.

3 Replies

0 Kudos

You state you have 180GB free, but how many domains do you have? Have you checed during the migration running what the free space was? When I run an MDSbackup on a 45 Domain MDS I run into 15GB of data compressed between 50 and 100GB uncompressd and when I do not have at least 200GB free space the backup fails

The mirgration will first make a copy of needed files (did you include logfiles?) and then it needs a tempfile to create the actual compressed file. So copy, tar and zip are the steps done, my guess is that you actually run out of space.

Regards, Maarten

Hi Maarten,

Thanks for your reply. Yes, i was running out of free space because of the junk files (like db snapshots).

I cleared all of them and the backup was created within 15mins of time.