Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Eric_Merillat
Contributor

Root Partition Full

Jump to solution

The root partition filled up overnight and using du I have narrowed it down to /opt/CPshrd-R80.40/database/postgresql/data/log is taking up the majority of the drive space.  Is there a safe way to purge these files and free up the drive space?  I searched the support site and this site for this issue but was not able to find anything.

Thanks in advance,

Eric

 

0 Kudos
1 Solution

Accepted Solutions
Sergey_Golyak
Participant

I assume that you have already resolved the issue. I had similar one, it was resolved by issuing $FWDIR/scripts/postgres_logs_off.sh.

View solution in original post

(1)
6 Replies
G_W_Albrecht
Legend
Legend

I looked at my /opt/CPshrd-R80.40/database/postgresql/data/ directory and found folder base to contain the big date - but o could not find /opt/CPshrd-R80.40/database/postgresql/data/log ! This is a R80.40 JT 92 SMS. Anyway, it is not a good idea to delete something in a CP installation without good reason and instructions.

Maybe it is the issue from sk166555: PostgresSQL database is very big and continues to grow ? Better involve TAC here...

0 Kudos
Eric_Merillat
Contributor

The database is normal sized it is just the log folder that is excessive.  The output from that SK shows it is not that issue.  

psql_client cpm postgres -c "select count(*) from dleobjectderef_data where deleted and dlesession=0"

count

-------

   858

(1 row)

Digging deeper into it there are several revisions that were created by the Web API when Cloudguard was deployed in NSX yesterday evening so wondering if that may have anything to do with this.  

Thanks,
Eric

 

0 Kudos
G_W_Albrecht
Legend
Legend

What about exploring the log folder ? Should also not be an issue to delete logs you do not need....

Still i would suggest to contact TAC - i smell a bug here 😎

0 Kudos
Eric_Merillat
Contributor

Yeah, I will have them open a TAC case, I expanded the root partition this morning to keep us working but it has already grown another 3 Gb today.  

Thanks!

0 Kudos
Sergey_Golyak
Participant

I assume that you have already resolved the issue. I had similar one, it was resolved by issuing $FWDIR/scripts/postgres_logs_off.sh.

View solution in original post

(1)
Eric_Merillat
Contributor

That was exactly the problem!  Someone had enabled debugging in postgres.  TAC found this and we turned it off and deleted the logs!  I should have come back and posted the solution but thanks for your answer!

0 Kudos