Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
KM1895
Participant

Problems with Show Package tool

 

hi,

 

Im trying to upgrade to the latest version of the show policy package tool, as the older version currently on the mgmt server, due to errors when trying to run it. The error is most likely caused by a timeout, due to a couple of rules that contain a large amount of objects.

 

But when i try to run the mvnw clean install, i get compilation errors:

 

[ERROR] Unable to locate the Javac Compiler in:
/opt/CPshrd-R80/jre_32/../lib/tools.jar
Please ensure you are using JDK 1.4 or above and
not a JRE (the com.sun.tools.javac.Main class is required).
In most cases you can change the location of your Java
installation by setting the JAVA_HOME environment variable.
[INFO] 1 error
[INFO] -------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] Management API Library Java 1.0.1 .................. FAILURE [ 1.013 s]
[INFO] java_sdk private ................................... SKIPPED
[INFO] Java examples ...................................... SKIPPED
[INFO] Web API Clone Host 1.0 ............................. SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.212 s
[INFO] Finished at: 2020-12-09T13:12:09+01:00
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile (default-compile) on project mgmt_api_library_java: Compilation failure
[ERROR] Unable to locate the Javac Compiler in:
[ERROR] /opt/CPshrd-R80/jre_32/../lib/tools.jar
[ERROR] Please ensure you are using JDK 1.4 or above and
[ERROR] not a JRE (the com.sun.tools.javac.Main class is required).
[ERROR] In most cases you can change the location of your Java
[ERROR] installation by setting the JAVA_HOME environment variable.

How do i go about installing JDK 1.4 or above, as i havent done this before?

The environment is currently running R80.10, with jumbo 203. Unfortunately, i dont think the customer will go along with an upgrade on this, as its being phased out, but we need the policy package for a project.

 

 

1 Reply
PhoneBoy
Admin
Admin

So you're running this on the management server itself?
A TAC case is probably in order here as you shouldn't need to install JDK there.