Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Patrick_CH
Participant

Permission Denied /dev/null

Jump to solution

Recently we created a separate User for a Management Tool. It worked normally until yesterday. Since Yesterday the User isn't able to do scp or something else. If the User logs in the following Message appears: 

-bash: /dev/null: Permission denied
-bash: /dev/null: Permission denied
-bash: /dev/null: Permission denied
-bash: /dev/null: Permission denied
-bash: /dev/null: Permission denied
-bash: /dev/null: Permission denied
-bash: /dev/null: Permission denied

Also if the User runs the Command SCP:

scp
Couldn't open /dev/null: Permission denied

The User has the Bash Shell as default and the AdminRole is assigned. 

What permissions should the /dev/null directory normally have?

 

 

 

 

0 Kudos
1 Solution

Accepted Solutions
PhoneBoy
Admin
Admin

[Expert@mgmt:0]# ls -la /dev/null
crw-rw-rw- 1 admin root 1, 3 Nov  7 13:54 /dev/null

I assume a chmod 666 /dev/null in expert mode would resolve this?

View solution in original post

9 Replies
_Val_
Admin
Admin

Is /dev/null mentioned anywhere in the user profile?

 

0 Kudos
Patrick_CH
Participant

No its not mentioned in bash_profile or bashrc

0 Kudos
_Val_
Admin
Admin

I would try to setup a second account with the same settings and see if the issue is reproducible. If it is, open a TAC case. 

Patrick_CH
Participant

The Problem also happens with a new created account. I will open a TAC Case. Thanks for your help. 

0 Kudos
PhoneBoy
Admin
Admin

[Expert@mgmt:0]# ls -la /dev/null
crw-rw-rw- 1 admin root 1, 3 Nov  7 13:54 /dev/null

I assume a chmod 666 /dev/null in expert mode would resolve this?

Patrick_CH
Participant

Thank you! That solved the Problem. Dont know why this was changed but now the users work normally again. 

0 Kudos
Daniel_
Collaborator

You should double check /dev/null. Can you post a

ls -l /dev/null

IMHO a script deleted /dev/null and created a new one. /dev/null isn't a normal file. It has to be a character device...

0 Kudos
(1)
_Val_
Admin
Admin

I do agree, we need to check what caused this in the first place. Just redefining permissions is not a solution but a workaround.

 

0 Kudos
(1)
Patrick_CH
Participant

I found the Script which deleted the /dev/null. The Script had a syntax error. After that i recreated the /dev/null as character Device and rebooted the Management Server. Since there it looks stable and did not happen again. 
Thank you all