Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Emanuel_Miut
Participant

Logging issues on MDSM

Hello, 

 

We encounter some logging issues on our MDSM(Gaia 77.30) and while checking /var/log it was fully utilised. I removed some older logs file and then it started logging again but not all traffic was logged.

 

While checking the connectivity between SMS and GW cluster, i noticed we only have established connection from GW passive nodes to sms. Tested with telnet on port 257 on SMS from active GW and connection worked. I restarted Provider-1 but behaviour is the same, log file is created but less logs than normal are logged.

The next step will be to failover the cluster to Standby nodes and reboot the other node ( which has no fwd established connection with SMS ).

Can you provide some feedback or maybe have some ideas how to handle this?

 

Thank you!

0 Kudos
4 Replies

Does the situation change if you install policy for the cluster?

 

Refer also sk98317 / sk40090

Emanuel_Miut
Participant

Installing policies on cluster does not change anything.

About the SK's you provided, one is how to retrieve logs and another one is in case the log file is corrupted and cannot be opened. I can open all log files but for few days back, the log files are very small.

 

I checked on GW's aswell, the same size for log files can be find on SMS and GW's.

I presume the active nodes are no longer sending fw logs and what i actually have is the passive node log.

Considering this i thought rebooting the active node will restart services and hopefully resolve the issue.

 

The FWD service is started on the active gw: 

#cpwd_admin list
cpwd_admin:
APP PID STAT #START START_TIME COMMAND MON
CPD 5063 E 1 [20:13:24] 1/3/2019 cpd Y
MPDAEMON 5097 E 1 [20:13:27] 1/3/2019 mpdaemon /opt/CPshrd-R75.40/log/mpdaemon.elg /opt/CPshrd-R75.40/conf/mpdaemon.conf N
CI_CLEANUP 5395 E 1 [20:13:46] 1/3/2019 avi_del_tmp_files N
CIHS 5407 E 1 [20:13:47] 1/3/2019 ci_http_server -j -f /opt/CPsuite-R75.40/fw1/conf/cihs.conf N
FWD 5409 E 1 [20:13:48] 1/3/2019 fwd N
RTMD 7376 E 1 [20:14:43] 1/3/2019 rtmd N

0 Kudos

Are you sure that your reviewing the same SKs, what is the output of the following command when run on the gateway side?

cpstat fw -f log_connection

Emanuel_Miut
Participant

Indeed, i was looking at different SK's. Will review the ones you provided.

As for the output for log_connections, on active nodes i have disconnected and on passive nodes the status is Connected.
0 Kudos