Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
pradeep_paka1
Participant

Java process very high in Smart Log server. How can we solve this.

Hi All,

We see Java process very high in Smart Log server. How can we solve this.

Tried reboot but still same..

top - 09:17:21 up 1:17, 1 user, load average: 10.42, 9.98, 10.04
Tasks: 246 total, 3 running, 243 sleeping, 0 stopped, 0 zombie
%Cpu0 : 18.8 us, 9.4 sy, 55.7 ni, 12.4 id, 0.0 wa, 1.0 hi, 2.7 si, 0.0 st
%Cpu1 : 24.6 us, 7.0 sy, 54.2 ni, 13.3 id, 0.3 wa, 0.3 hi, 0.3 si, 0.0 st
%Cpu2 : 22.7 us, 6.3 sy, 63.7 ni, 7.0 id, 0.0 wa, 0.3 hi, 0.0 si, 0.0 st
%Cpu3 : 22.7 us, 5.0 sy, 62.0 ni, 10.0 id, 0.0 wa, 0.3 hi, 0.0 si, 0.0 st
%Cpu4 : 3.3 us, 9.3 sy, 80.4 ni, 6.6 id, 0.0 wa, 0.3 hi, 0.0 si, 0.0 st
%Cpu5 : 2.0 us, 6.3 sy, 82.7 ni, 8.3 id, 0.0 wa, 0.3 hi, 0.3 si, 0.0 st
%Cpu6 : 3.7 us, 8.4 sy, 78.9 ni, 8.4 id, 0.0 wa, 0.3 hi, 0.3 si, 0.0 st
%Cpu7 : 2.7 us, 7.0 sy, 82.9 ni, 7.0 id, 0.0 wa, 0.3 hi, 0.0 si, 0.0 st
KiB Mem : 32665068 total, 679052 free, 14554144 used, 17431872 buff/cache
KiB Swap: 35664264 total, 35662720 free, 1544 used. 17265012 avail Mem

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
10601 admin 39 19 0.475t 0.012t 1.839g S 412.3 39.3 330:31.00 java
11078 admin 39 19 283364 142872 9884 S 85.4 0.4 57:47.39 log_exporter
10943 admin 39 19 711044 293532 84516 S 72.1 0.9 66:15.63 log_indexer
4399 admin 20 0 399532 98912 57660 S 57.1 0.3 7:36.52 lea_session
10115 admin 20 0 1086348 124152 37048 S 33.6 0.4 23:53.42 fw_full
22586 admin 20 0 109108 13268 6740 S 0.7 0.0 0:00.59 sensor
10 admin 20 0 0 0 0 S 0.3 0.0 0:03.75 rcu_sched
21 admin 20 0 0 0 0 S 0.3 0.0 0:01.12 rcuos/1
28 admin 20 0 0 0 0 S 0.3 0.0 0:01.10 rcuos/2

0 Kudos
4 Replies
the_rock
Authority
Authority

Hi,

Im not smart log expert myself, but just logically, have you tried maybe restarting the process itself? For example, if you do ps -auxw and then grep for java, it would show you process ID, then you can do kill -9 pid (so in your example would be kill -9 10601), but process ID would change if you do this again. Also, have you attempted cpstop/start? I see you say you rebooted already...hm, when did you first start noticing this? Is this DEDICATED smart log appliance only?

0 Kudos
Mike_A
Advisor

What version are you running on your SmartLog server? Also how  much memory is in the SmartLog server? 

Check sk123417

G_W_Albrecht
Legend
Legend

the_rock
Authority
Authority

You got excellent advice from 2 pretty experienced CP guys, so hopefully that fixes it : ). Let us know!

0 Kudos