Create a Post
Showing results for 
Search instead for 
Did you mean: 

CDT v1.6 is GA!

Hi all,

I am very happy to announce the release of version 1.6 of the CDT - Central Deployment Tool, which now also supports VSX.

Version 1.6 introduces the following new features, as well as bug fixes and minor additions:

  • VSX support – including gateways, HA clusters and VSLS clusters
  • Customized RMA backup & restore - add additional files to the backup
  • Resume mode – quickly resume after resolving issues with failed deployment plans
  • CloudGuard support - Gateways and CloudGuard Controllers R80.10 and above


Version 1.6 will also be included in version releases starting R80.30 on all Security Management and Multi-Domain Management machines.


Please visit sk111158 for download and usage instructions.

Any comments or suggestions for CDT will be appreciated!

9 Replies

Hi Arik,

I having some troubles updating 5600 cluster from 77.30 to 80.10 using CDT 1.6

it worked fine with the 3200 and 5400

did hear about any similar problems

0 Kudos

TAC case, TAC case..
0 Kudos

The documentation at needs to be updated.


In the section "Generating an Installation Candidates List" it notes the following steps to generate a candidate list:


# mdsenv <IP Address or Name of Domain Management Server>

# ./CentralDeploymentTool -generate <Name of Candidates List file>.csv <IP Address or Name of Domain Management Server>

I switch to the environment I want to generate a list for.  And then I issue the command:

./CentralDeploymentTool -generate mylist.csv MyDMS

And CDT replies with Invalid number of arguments.  It does not matter if I use the name or IP for my MDS.


Switching over to advanced mode, it seems to be a little happier with the syntax.  But since I don't have a deployment plan (or a an example of a basic plan to just collect data) it yells at me about that.


The syntax that the tool offers as a part of the error message is:

-generate -candidates=<file name> -deploymentplan=<filename.xml> [-server=<Domain Management Server IP>] [-filter=<file name>]

When I use the -candidates to generate the list it looks like it takes it out of basic mode and ends up wanting a deployment plan.

0 Kudos

Hi folks,

I guess I run into the same issue as Tommy did... Any solution? Thx in advance!

0 Kudos

Hello Tommy,

I  was having similar problem . If you're running a MDS environment please try to use the following command and see if it will make any difference:

./CentralDeploymentTool -generate -candidates=NAME.csv -deploymentplan=my_deployment_plan.xml -server=CMA_IP 

I think the problem is coming if you're using the MDS name/ip instead of the CMA name/ip.


0 Kudos

Any reason why I cannot access that SK? I try accessing from my Employer User Center login and I get a lock on that SK.
0 Kudos
Employee Employee

Hi Arik,


Is there any documentation available for 1.7.1 as it's shipping with R80.40.


I've got a ticket open and they don't have documentation either.


Getting the 'invalid number of arguments' and it is not resolved with the info in the sk111158 or sk157714.



Paul G.

0 Kudos

Hey Paul,

The only documentation for 1.7.1 i have is the admin guide listed here:

I don't know if you are asking for this but still...

Vince M

0 Kudos
Employee Alumnus
Employee Alumnus

Hi Paul,

You can always find the admin guide  for the newest CDT in sk111158 under the "Downloads and Documentation" section.

Link to V1.7.1 admin guide(the same admin guide as in Vince's comment):

In addition you can always see the usage for the relevant mode from CLI:

# ./CentralDeploymentTool

CentralDeploymentTool Usage Options:
-basic, -b see basic usage
-advanced, -a see advanced (Deployment Plan) usage
-rma RMA usage
-version, -v display Central Deployment Tool version

Example: ./CentralDeploymentTool -a


0 Kudos


Epsum factorial non deposit quid pro quo hic escorol.

Upcoming Events

    CheckMates Events