Create a Post
Showing results for 
Search instead for 
Did you mean: 

API with MDS environment

Hello team,

I'm trying to use API in specific Domain of my Multi Domain environment.  For example:

MDS> mgmt login domain MYDOMAIN user admin password test

I can see objects, services, etc... from this domain when i use the corresponding show api commands, but when I add objects like:

>mgmt add host name daniprueba ip-address

The object is created successfully but then I cannot see the new object via smarconsole. Do you know where is this object created?

It works fine if I use the command-line console from MYDOMAIN smartconsole.

I have tried to add them adding the specific domain with the same result:

>mgmt add host name testobject ip-address -d MYDOMAIN -u admin -p test 

Thank you in advance.

0 Kudos
2 Replies

Did you execute a publish action afterwords?

Without that, the objects won’t exist.

Likewise for any changes you make via the API: a publish action is required for them to take effect.


I tried yesterday but it did not work. I have tested it again and the object appears in the domain. Thank you again for your help (you are always there!)


MDS> mgmt login domain MYDOMAIN user admin password test

MDSmgmt add host name TESTOBJECTS ip-address

MDSmgmt publish

After the publish, the session opened in smartconsole updates the database correctly.

0 Kudos


Epsum factorial non deposit quid pro quo hic escorol.

Upcoming Events

    CheckMates Events