Create a Post
Showing results for 
Search instead for 
Did you mean: 

Cannot install Check Point Mobile Access Portal Agent on Windows 10

Good day,

I'm trying to install the Check Point Mobile Access Portal Agent 800.007.040 on a domain joined Windows 10 computer but launching the install, I receive the following message :

The Mobile Access Portal Agent installer failed to install the certificate and cannot work properly. The certificate is required for secure communication with the corporate site.

Install the Mobile Access Portal Agent again, and make sure to Approve the certificate during the installation process.

I removed our corporate VPN and antivirus (Kaspersky) but the problem still remains.

When looking at the msi log file, the following comes up :

CreateCertificate:    14:48:28:911  Initialized.

CreateCertificate:    14:48:28:912  Install path is:

CreateCertificate:    14:48:28:912  C:\Users\test\AppData\Local\CheckPoint\MobileAccess\

CreateCertificate:    14:48:28:913  Update current certificate or create new one

CreateCertificate:    14:48:28:913  There is no installs.ini file, checking default profile in profiles.ini file.

CreateCertificate:    14:48:28:914  Default profile has not been found in profiles.ini file

CreateCertificate:    14:48:28:919  Successfully Opened the System Store

CreateCertificate:    14:48:28:921  The desired certificate wasn't found

CreateCertificate:    14:48:28:921  Store Closed

CreateCertificate:    14:48:28:922  Try to delete file by path:

CreateCertificate:    14:48:28:922  C:\Users\test\AppData\Roaming\CheckPoint\MobileAccessDeployment\ca-certificate.pem

CreateCertificate:    14:48:28:923  Certificate isn't exist - create new certificate

CreateCertificate:    14:48:28:923  Getting CShell's PID

CreateCertificate:    14:48:28:924  PID is:

CreateCertificate:    14:48:28:925 

CreateCertificate:    14:48:28:926  Couldn't get the CShell's process id.

CreateCertificate:    14:48:28:927  Try to delete file by path:

CreateCertificate:    14:48:28:928  C:\Users\test\AppData\Roaming\CheckPoint\MobileAccessDeployment\certificates.jks

CreateCertificate:    14:48:28:928  Generating RSA key (private key for CA certificate)

CreateCertificate:    14:48:29:482  Generating x509 certificate (CA certificate)

CreateCertificate:    14:48:29:488  Writing certificate to disk

CreateCertificate:    14:48:29:489  Directory doesn't exist or wrong path

CreateCertificate:    14:48:29:489  Create CheckPoint directory

CreateCertificate:    14:48:29:490  Directory doesn't exist or wrong path

CreateCertificate:    14:48:29:490  Create MobileAccessDeployment directory

CreateCertificate:    14:48:29:491  generate RSA key for CSR

CreateCertificate:    14:48:29:745  Generating a Certificate Request

CreateCertificate:    14:48:29:751  sign CSR with CA certificate

CreateCertificate:    14:48:29:756  Create p12 store

CreateCertificate:    14:48:29:760  Add certificate to java keystore

CreateCertificate:    14:48:29:987  java home has been detected

CreateCertificate:    14:48:29:988  C:\Program Files\Java\jre1.8.0_231


CreateCertificate:    14:48:30:283  Wait response is:

CreateCertificate:    14:48:30:284  0

CreateCertificate:    14:48:31:23  Wait response is:

CreateCertificate:    14:48:31:24  0

CreateCertificate:    14:48:31:25  Adding certificate to trusted root

CreateCertificate:    14:48:31:28  Successfully Opened the System Store

CreateCertificate:    14:48:31:29  Successfully opened file

CreateCertificate:    14:48:31:29  Successfully got file attributes

CreateCertificate:    14:48:31:29  Successfully Read file

CreateCertificate:    14:48:31:30  Unabled to add certificate to store.

CreateCertificate:    14:48:31:30  Store Closed

CreateCertificate:    14:48:31:31  AddCertificateToTrustedRootStore failed.

CreateCertificate:    14:48:31:31  Try to delete file by path:

CreateCertificate:    14:48:31:32  C:\Users\test\AppData\Roaming\CheckPoint\MobileAccessDeployment\cshell.p12

CreateCertificate:    14:48:31:32  Try to delete file by path:

CreateCertificate:    14:48:31:32  C:\Users\test\AppData\Roaming\CheckPoint\MobileAccessDeployment\CshellFileForAnswer.txt

CreateCertificate:    14:48:31:33  FAILURE

CreateCertificate:    14:48:31:33  Try to delete file by path:

CreateCertificate:    14:48:31:34  C:\Users\test\AppData\Roaming\CheckPoint\MobileAccessDeployment\certificates.jks

Anybody know why it's causing these errors and how I can go about getting it to work?

Thank you.

0 Kudos
13 Replies

This looks like a clue: "AddCertificateToTrustedRootStore failed"
I believe this requires admin privileges, do you have that on the computer?

0 Kudos

In fact the process does not need any admin rights, a standard user can run it and the certificate gets installed.

the user logged in is domain admin and computer admin.

0 Kudos

I have the same issue. Any luck yet finding a solution?

0 Kudos

Any update on this?

0 Kudos

I ask user to install 64 bit java, not 32 bit. the problem was fixed.

0 Kudos

That is not the solutions ... i have java 64bits installed and have that issue...

At this time 

CreateCertificate:    14:48:31:28  Successfully Opened the System Store.

we are talking about windows cetificates store or java keytool ? 

0 Kudos

Hi alesandro

The MSI creates a temporary installation file that is launched to install agent. This temporary file need to be located on a local folder.

So, probably the folder C:\Users\test\AppData\Roaming\CheckPoint is considered "remote" because it is part of the roaming profile which is syncronized with the roaming profile process.


We have solved that issue this way.


Best regards.

0 Kudos

Please, can  you describe step-by-step how have you resolved this issue?

0 Kudos

Hello Grigoriy,

exclude the folder C:\Users\test\AppData\Roaming\CheckPoint from the roaming profile.

The folder must be local.

I have fixed it that way.

Sorry, don't have time to write a step-by-step guide.


0 Kudos

Hello jbIT 

Is the folder/path the default one? In this case C:\Users\test\AppData\Roaming\CheckPoint is this by default?

Or you can select where to install it? 

Thank you in advance! 

0 Kudos

Hello Malware, from what i know, yes it is the default and you can't change it.


Best regards.


And how exactly are you extracting the folder/path? I was trying to find info on the roaming profile as well? Could you please let me know, what is this profile? Is it centrally located or? 

Thank you for your help! 

0 Kudos


Have you found any solution?

0 Kudos


Epsum factorial non deposit quid pro quo hic escorol.

Upcoming Events

    CheckMates Events