Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Simon_Macpherso
Advisor

Management API VPN Settings

Hello,

When configuring VPN settings via the management API using mgmt_api, the VPN domain and VPN domain type are not being set. 

Using Management APIv1.9

The following example command runs successfully but the VPN domain and VPN domain type are not configured. 

mgmt_cli -r true set simple-cluster name 'cg-cluster-1' application-control true vpn true vpn-settings.vpn-domain 'demo_vpn_domain' vpn-settings.vpn-domain-type manual vpn-settings.link-selection.ip-selection use-statically-nated-ip vpn-settings.link-selection.ip-address '111.111.111.111'
 
[Expert@demomgmt:0]# mgmt_cli -r true set simple-cluster name 'cg-cluster-1-demo' application-control true vpn true vpn-settings.vpn-domain 'demo_vpn_domain' vpn-settings.vpn-domain-type 'manual' vpn-settings.link-selection.ip-selection use-statically-nated-ip vpn-settings.link-selection.ip-address '111.111.111.111'
  

---------------------------------------------
Time: [23:59:16] 11/7/2023
---------------------------------------------
"set simple-cluster" succeeded (100%)
tasks:
- task-id: "01234567-89ab-cdef-b5a7-0e16133d34cd"
task-name: "set simple-cluster"
status: "succeeded"
progress-percentage: 100
suppressed: false
task-details:
- message: "Successfully finished"

 

---------------------------------------------
Time: [23:59:17] 11/7/2023
---------------------------------------------
"Publish operation" succeeded (100%)

The object used for the VPN domain is a network group object.  

0 Kudos
8 Replies
Tal_Paz-Fridman
Employee
Employee

I managed to reproduce the issue in my lab.

I will forward it to the relevant R&D owner.

Simon_Macpherso
Advisor

The settings configured in the vpn-settings parameter can be successfully configured when using the add simple-gateway endpoint management APIv1.9. So the issue may be specific to the add simple-gateway and or set simple-gateway endpoints.

0 Kudos
jimmy1
Participant

Yes it works with the simple gateway, but not with the simple cluster.

I need it for both, the gateway and the cluster so please fix that!

0 Kudos
PhoneBoy
Admin
Admin

To ensure you receive a fix for this, I recommend a TAC case: https://help.checkpoint.com 

0 Kudos
Simon_Macpherso
Advisor

@PhoneBoy A TAC was opened for this a few weeks ago. Its currently sitting with R+D. 

0 Kudos
Tal_Paz-Fridman
Employee
Employee

I was told by relevant R&D owner that it will be fixed in a JHF but it is still not known which one.

0 Kudos
Simon_Macpherso
Advisor

Thanks

0 Kudos
jimmy1
Participant

I am using the web-API and I have the same issue that the VPN-Domain is not beeing set...

Please fix that!

0 Kudos

Leaderboard

Epsum factorial non deposit quid pro quo hic escorol.

Upcoming Events

    Tue 23 Apr 2024 @ 11:00 AM (EDT)

    East US: What's New in R82

    Thu 25 Apr 2024 @ 11:00 AM (SGT)

    APAC: CPX 2024 Recap

    Tue 30 Apr 2024 @ 03:00 PM (CDT)

    EMEA: CPX 2024 Recap

    Thu 02 May 2024 @ 11:00 AM (SGT)

    APAC: What's new in R82

    Tue 23 Apr 2024 @ 11:00 AM (EDT)

    East US: What's New in R82

    Thu 25 Apr 2024 @ 11:00 AM (SGT)

    APAC: CPX 2024 Recap

    Tue 30 Apr 2024 @ 03:00 PM (CDT)

    EMEA: CPX 2024 Recap

    Thu 02 May 2024 @ 11:00 AM (SGT)

    APAC: What's new in R82
    CheckMates Events