Who rated this post

Showing results for 
Search instead for 
Did you mean: 

Cannot use the Central deployment tool on R80.40 gateways

Hello team,


when I try to use the CDT on gateways R80.40, I have the following message and the execution stop.

An error has occurred in stage DA cloud packages prevention of machine cnlgnfwa0002:

Error code 31 - CPUSE cannot be prevented from searching for new packages while installing.
Try again and Contact Check Point support if this problem persists.


When I look deeply in log files I can see this error : 

Error code 41 - Error executing a CPUSE operation on a remote machine.

Mon Sep 26 09:37:14 2022 *N* [Main]: Restoring initial configuration on dehnvfwa0002 - DA cloud packages prevention
Mon Sep 26 09:37:15 2022 *E* [Main]: DA cloud packages prevention Cleanup error:
Invalid format in da_cli response.
Error: Parameter is not a valid configuration key, please make sure argument list is correct and match allowed keys.[PING_TRACE,PING_DEBUG,IS_INSTALLED_HOTFIXES_SEND_DISABLED,ENFORCE_NEW_DA,FORCE_OFFLINE]

Try again and Contact Check Point support if this problem persists.

The build of the installed Deployment Agent must be 2131 or higher.



I would like to add that the same Deployment plan works on R80.20 gateways but fails only on R80.40 :(. 

I'm using the CDT to update the deployment agent because my gateway don't have access to internet/Checkpoint Cloud. 

But it looks like the CDT needs the DA updated to be used, Am I correct ?

If yes, I believe that it will means that I will have to upload the file manually on all gateways and install it manually on them and then I will be able to use the CDT, is that also correct ? 

Is there a way to bypass that check and let me use the CDT to at least just install the latest DA first  ?

I also tried to do the simpliest  deployment plant to install the latest DA but I still have the same error message. 

here my CDT to install latest DA : 

<name value="Test install DA" />
<description value="This DP is to install DA" />
<update_cpuse value="false" />
<connectivityupgrade value="false" />
<push_file local_path="/home/admin/DA/DeploymentAgent_000002229_1.tgz" remote_path="/var/log/DeploymentAgent_000002229_1.tgz" />
<execute_command command="clish -c 'installer agent install /var/log/DeploymentAgent_000002229_1.tgz'" />
<execute_command command="rm /var/log/DeploymentAgent_000002229_1.tgz" />
<log level="NORMAL" value="Logs script" />


Thanks in advance for your replies,

0 Kudos
Who rated this post