Create a Post
Showing results for 
Search instead for 
Did you mean: 

VSXHA missing routes on External Virtual Router context



We are facing with the following issue in our VSXHA (active/standby) deployment (2x23500 GW's, Gaia R80.30):


VSX topology is as follows:

        Outside world



External_vRouter (VS1)




Virtual Firewall/system (VS2)



Inside networks (services)

VS0 has all setup and working smoothly (routes, interfaces, policy,...).

VS1 (vRouter) is direct contact with outside networks/Internet via bond100.3000 interface. It has it's own routing defined. 

Virtual System 2 (firewall under this external vrouter) has connection to inside networks via bond200.XXX interfaces. And connection with vrouter via wrp link wrp128 (we put here private ip for PtP virtual link).

The problem is that VS1 (virtual router) goes to down state on one VSX cluster member/GW when we put default route to VS2 (virtual firewall), pointing to vrouter object. When we delete this default route on VS2 topology, down state goes to standby as should on VS1.

Other problem is that when VS1 is initialy configured all routes defined are correctly pushed to both GW's (VS1 context), and states of VS1 are stable active/standby.

But after that, when we define create VS2 and define inter-connection with VS1 and default route to VS1 (vrouter), VS1 state on one GW goes to down. 

After rebooting no matter which GW (GW1 or GW2), that rebooted GW comes up with deleted static routes for defined for VS1 context (virtual router). 

We have tried everything we know, deleting VS1, VS2 and recreate both again, but all time we are facing with exactly the same issue with route deletion after rebooting GW's, and this wrp link issue.

WRP link on VS2 is defined as Leads to Internet (in topology) but it does not create default route automatically on VS2. We need to create default route that is over vrouter because of that, but then VS1 state goes to down on one GW.

We investigated reason for this Down state and it is like active device interface check PROBLEM for this wrp128 interface.

On DOWN VS1 GW (inboud DOWN, outbound DOWN) on Active VS1 GW (inboundUP, outbound DOWN).

We tried to switch CCP to broadcast without success, to change kernel parameter for routing/topology cync between cluster members to 1, no success.


Please advice here,




0 Kudos
12 Replies
This widget could not be displayed.