Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Sanjay_S
Advisor

SNMP config in VSX

Hi All,

We are running VSX on R77.30. We need to monitor the interfaces of both VSX 0 and 1 environments. But we are seeing on interfaces of Mgmt VSX that is VSX 0. Below was the config.

set snmp mode default
set snmp agent on
set snmp agent-version any
set snmp community xxxx read-only
add snmp usm user xxxx security-level authPriv xxxx
set snmp usm user xxxx usm-read-write

Then changed to below now, still it is not working.

set snmp mode vs
set snmp agent on
set snmp agent-version any
set snmp community xxxx read-only
add snmp usm user xxxx security-level authPriv xxxx
set snmp usm user xxxx usm-read-write

 

However in R80.10 i am able to monitor all the interfaces and below is the config.

set snmp mode vs
set snmp vs-direct-access off
set snmp agent on
set snmp agent-version any
set snmp community xxxx read-only
add snmp usm user xxxx security-level authPriv xxxx
set snmp usm user xxxx vsid (numbers)

 

Is there any limitation in R77.30?

0 Kudos
5 Replies
PhoneBoy
Admin
Admin

As far as I know this should work on R77.30.
Note that R77.30 is End of Support and you should really upgrade to a supported release.
0 Kudos
genisis__
Advisor

This may not be the correct thread, but I just uninstalled Jumbo HFA118 on my VSX appliances (running R80.40), and installed the JHFA125.

Since doing this SNMP seem to be broken, is there any known issues?  I have raised a TAC case which is linked to another TAC case (which related to installing the Jumbo).  Its been about 6hrs and not a single TAC resource has even bothered to update the case or call me, I have uploaded a cpinfo to the case.

0 Kudos
Eitan_Gilad-Lug
Employee
Employee

Hello, 

can you please share the case number?

thank you

Eitan

 

0 Kudos
genisis__
Advisor

Will ping you privately with the SR

0 Kudos
genisis__
Advisor

Issue resolved, it looks like a corrupted snmpd.conf file; action plan from TAC with some bits I added in:

- copy all snmp configuration from clish

- remove snmp configuration

- save config

expert

rm /etc/snmp/snmpd.conf

#/bin/snmp_xlate snmp /etc/snmp/snmpd.conf "" < /config/active

clish

paste back snmp configuration and reenable agent.

The snmpd.conf file would then be updated with an specific changes.

 

The part that is not clear is how the Jumbo caused this, but as my issue is now fixed I can move on.

0 Kudos