Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
John_Fleming
Advisor

SNMP Installed updates bug?

Jump to solution

So this is kind of strange. Part of the svnUpdatesInfo tree doesn't populate until you walk the entire tree when snmpd first starts.

#snmpd auto restarts btw

[Expert@MDS1:0]# pkill snmpd 


[Expert@MDS1:0]# snmpwalk -v2c -c public 127.0.0.1 svnUpdatesInfo.10.1.5
CHECKPOINT-MIB::svnUpdatesInfo.10.1.5 = No Such Instance currently exists at this OID

[Expert@MDS1:0]# snmpwalk -v2c -c public 127.0.0.1 svnUpdatesInfo.10.1.5
CHECKPOINT-MIB::svnUpdatesInfo.10.1.5 = No Such Instance currently exists at this OID

[Expert@MDS1:0]# snmpwalk -v2c -c public 127.0.0.1 svnUpdatesInfo.10.1.5
CHECKPOINT-MIB::svnUpdatesInfo.10.1.5 = No Such Instance currently exists at this OID

# output is just throwing away the full table walk output to show now 10.1.5 now works.

[Expert@MDS1:0]# snmpwalk -v2c -c public 127.0.0.1 svnUpdatesInfo > /dev/null

[Expert@MDS1:0]# snmpwalk -v2c -c public 127.0.0.1 svnUpdatesInfo.10.1.5
CHECKPOINT-MIB::svnUpdatesInfo.10.1.5.1.0 = STRING: "Installed"
CHECKPOINT-MIB::svnUpdatesInfo.10.1.5.2.0 = STRING: "Installed"
CHECKPOINT-MIB::svnUpdatesInfo.10.1.5.3.0 = STRING: "Available for Download"
CHECKPOINT-MIB::svnUpdatesInfo.10.1.5.4.0 = STRING: "Available for Download"

if I now kill snmpd walking anything from svnUpdatesInfo.10.1.5 breaks again until i walk svnUpdatesInfo

 

0 Kudos
Reply
1 Solution

Accepted Solutions
John_Fleming
Advisor

Fix has been sent out BTW. I don't think its part of a jumbo yet. 

View solution in original post

0 Kudos
Reply
5 Replies
John_Fleming
Advisor

Oh.. and BTW svnUpdatesInfo.10 ?

Not in the checkpoint mib.

This is R80.40 BTW BTW - JHA 78

0 Kudos
Reply
John_Fleming
Advisor

I think I found the problem. After I put snmpd in debug all mode I stumbled across this.

handler:calling: calling handler old_api for mode GET
trace: netsnmp_old_api_helper(): helpers/old_api.c, 370:
old_api: evil_client: checkpoint
trace: netsnmp_call_handler(): agent_handler.c, 549:
handler:returned: handler old_api returned 0

 

So maybe this just needs to be converted to good client. Its like that Simpson's episode where the krusty doll was switched to evil. 

0 Kudos
Reply
cdooer
Participant

Did you ever find a solution to this? I managed to get it to work once, on one gateway, but now my SNMP monitoring tool is telling me that the OID isn't supported. I would love to get this working in order to easily keep track of updates installed on all of our gateways.

0 Kudos
Reply
John_Fleming
Advisor

I have a ticket open with checkpoint. They've replicated the issue just waiting for them to get back to me.

The band aid for now is to just do a full walk of svnUpdatesInfo. Maybe schedule the walk however often your comfortable with? After you walk svnUpdatesInfo  svnUpdatesInfo.10.1.5 should populate.

0 Kudos
Reply
John_Fleming
Advisor

Fix has been sent out BTW. I don't think its part of a jumbo yet. 

View solution in original post

0 Kudos
Reply