Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
equilibrium
Explorer

Memory consumption TP_CONF_SERVICE

Good night,

I manage some Check Point Gateways with version R80.40 which are showing high memory consumption, to identify what is consuming memory in these
equipment I use the command "for ii in /proc/*/status ; do echo ; awk '/VmSize|Name|^Pid/ {printf $2 " " $3}' $ii ; done | sort -k 3 -n -r | head -10" this
command shows me that the TP_CONF_SERVICE process always consumes around 1 GB of memory on each Gateway.

As informed in the link https://community.checkpoint.com/t5/Management/New-process-in-R80-40-management/td-p/89200 this service is an autoupdater in which it was
enabled by default in R80.40 versions but when we talk about a vsx environment in which we have for example 10 contexts the memory consumption of this service only
is 10 GB.

To disable this service and the Gateways continue to function as R80.x versions prior to R80.40 we tried to enter the command
"/opt/AutoUpdater/latest/bin/autoupdatercli disable TEX_Engine" and also the autoupdatercli disable tp_conf command however after entering the cpwd_admin list command
the TP_CONF_SERVICE process remains active and the command "for ii in /proc/*/status ; do echo ; awk '/VmSize|Name|^Pid/ {printf $2 " " $3}' $ii ; done | sort -k 3 -n -r | head -10""
continues showing this process with the consumption of 1 GB of memory.

After entering the command "/opt/AutoUpdater/latest/bin/autoupdatercli show" we see the TEX_Engine and tp_conf processes as download-scheduler-active and install-scheduler-active false, false however
the memory consumption of this process continues at 1 GB of memory.


 component-name: TEX_Engine
   component-branch: TEX_engine_R8040_AutoUpdate
   GA-Version: 0
   download-period-seconds: 10800
   install-period-seconds: 10860
   download-scheduler-active: false
   install-scheduler-active: false
   download-action: idle
   install-revert-action: idle

component-name: tp_conf
   component-branch: GOT_TPCONF_AutoUpdate
   GA-Version: 0
   download-period-seconds: 10800
   install-period-seconds: 10860
   download-scheduler-active: false
   install-scheduler-active: false
   download-action: idle
   install-revert-action: idle

I would like to know if we can disable this service so that it does not consume these memory values ​​anymore, do you know if the command "/opt/AutoUpdater/latest/bin/autoupdatercli disable TEX_Engine"
works correctly on version R80.40.

Thank you all.

 

0 Kudos
1 Reply
_Val_
Admin
Admin

Several questions:

  1. Which blades are enabled on your FWs?
  2. What "fw ctp pstat" shows concerning memory utilization?
  3. Why this post is pre-formatted? Any specific need for that?
0 Kudos