Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
oconnork
Participant

Command set selfpasswd

Jump to solution

Hello team,

I hope someone could help me. I have an issue when I push the command 'set selfpasswd' (on clish) on my appliance, the shell change from clish to expert. Do you know why and how I can avoid this ? 

Please see below the version of my appliance. 

XXX> show version all
Product version Check Point Gaia R80.20
OS build 101
OS kernel version 2.6.18-92cpx86_64
OS edition 64-bit

0 Kudos
1 Solution

Accepted Solutions
oconnork
Participant

Well I don't know why but I tried to change my shell in a different way and it worked.

XXX>set user shell admin /etc/cli.sh

XXX>save config

The command set selfpasswd don't change anymore the shell from cli to bash. 

Before I was using this command to change my shell : chsh -s /etc/cli.sh admin (in expert shell)

View solution in original post

11 Replies
the_rock
Authority
Authority

Weird...I dont have R80.20 to test, but tried on R81 and I dont have that problem. What is exact command you ran?

Andy

0 Kudos
oconnork
Participant

I type 'set selfpasswd' then put my old password then I put the new password and that's it. 

After that, when I disconnect and reconnect with same user, new password, my shell is changed to expert (linux shell) instead of clish as it was before using the command.

 

0 Kudos
oconnork
Participant

and many thanks for your quick reply Andy,

Kindly,

Kalei

0 Kudos
the_rock
Authority
Authority

This is what I did in the lab:

R81> set selfpasswd oldpass password@! passwd password@!1

R81> save config

After that, just logged in with new password and set expert password and also enabled winscp with chsh command, thats it. 

0 Kudos
oconnork
Participant

Command I run :

R80.20> set selfpasswd
Old password:
New password:
R80.20> save config

R80.20> exit

After that i have exited the console and log in again, my shell is in expert instead of clish.. Any explanation for this ? 

0 Kudos
the_rock
Authority
Authority

Not real sure, sorry. I tried this in R80.20 as well and worked fine, no issues. You may want to contact TAC about it. I also confirmed that BEFORE making the change, my shell was indeed in /bin/bash and not in regular shell.

0 Kudos
PhoneBoy
Admin
Admin

Sounds like a bug and you should involve TAC.

0 Kudos
oconnork
Participant

Well I don't know why but I tried to change my shell in a different way and it worked.

XXX>set user shell admin /etc/cli.sh

XXX>save config

The command set selfpasswd don't change anymore the shell from cli to bash. 

Before I was using this command to change my shell : chsh -s /etc/cli.sh admin (in expert shell)

View solution in original post

the_rock
Authority
Authority

That makes sense, but why you had to do it, its beyond me, because I tried it on 2 R80.20 versions and no issues, though shell was in /bin/bash already.

0 Kudos
PhoneBoy
Admin
Admin

Changing your shell using chsh is not supported.
Most OS settings are part of a configuration database which updates the various Linux files like /etc/passwd, /etc/hosts, and so on.
Any manually applied changes like that will be overridden.

There are a handful of changes you might need to make that aren't managed via clish/WebUI.
Those you should be able to make safely.

the_rock
Authority
Authority

O, interesting...I always used to do it via clish, though lately I just execute it via web UI.

0 Kudos