Create a Post
Showing results for 
Search instead for 
Did you mean: 

CLI on Embedded Gaia

Are there many people here that use the CLI much on the small boxes like the 1100 / 1400 series?

I have created my own database for preping a base config for normal GAIA and have been working the last copuple of days to get the syntax on all commands we need to set the standard settings and maybe add interfaces / static routes etc.

I was working on a job where I don't have a Internet Connection configured as the box is connected between a MPLS-trunk and some local network with a DMZ and a local LAN.

First thing I ran into, you cannot set a default route except for the one in the internet connection.

Second thing, by default the LAN ports are part of a switch, so to use  each port as a separate network port you remove the switch, then set interfaces' IP addresses however here I get an error: The settings overlap with those of another network or bridge

Third I cannot find the way to prepare the box for doing SIC from management (when adding a SMB cluster member you need to set SIC during the ADD process, you cannot use first connect.

Commands used each with their appropriate options:

connect security-management 

set log-server-configuration 

After this I checked through the GUI and there was nothing filled in the SIC part, so how do I setup the 1400 so it will accept a SIC request? I know on the Edge it was:

set smp server registrationkey <password> gatewayid <GW-Name> connect enabled

However that is no longer there.

There are multiple other things I ran into that do not work the way they are supposed to, but those are all already in the case I openend for this.

Version I worked with is 77.20.70

Regards, Maarten
3 Replies

For your last question, there is a script called (available in Expert mode) that appears to allow you to set the SIC password.


Thanks Damien, with that I found the most simple command to get the SIC Password set:

fw sic_init <password>

Which can be run from clish as well, so yep this one saved the day.

all the other issues I found are quite problematic but also there for most I found workarounds. Like when you remove the LAN1_Switch from the command line you need to reboot before you can assign IP's to any of the interfaces, so we came with a set of commands to execute before upgrading to the latest firmware, then (automatic) reboot and then continue with the set interface ipa-address commands.

Regards, Maarten
0 Kudos

I want to add that i have published much about autoconf.clish here already - see for example USB First Time Config using autoconf.clish files  - How it is written



Epsum factorial non deposit quid pro quo hic escorol.

Upcoming Events

    CheckMates Events