Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Reevsie147
Contributor

Automatic Proxy ARP issue on R80.40

Jump to solution

Hi all,

Am having a bit of an odd issue with automatic proxy ARP on an R80.40 cluster and was wondering whether somebody maybe able to shed some light on it?

Whenever I configure an automatic NAT rule and push the policy, the firewall seems to be applying a strange MAC address to the proxy ARP entry shown when I run "fw ctl arp":

(x.x.x.150) at 00-00-00-00-64-65 interface x.x.x.5

(Note: I have obfuscated the IP addresses but they are correct)

This is also verified if I look at the arp table on my upstream router:

x.x.x.150 ether 00:00:00:00:64:65 C eth1

It doesn't seem to matter what automatic entries I make, they all seem to show the same odd MAC.

If I create a manual NAT rule, define a manual Proxy ARP entry in GAiA and push the policy, it works fine and shows the MAC of the active cluster member:

(x.x.x.150) at 00-0c-29-90-3f-bf

The strange MAC seems to look like a little like a Magic MAC that ClusterXL used to use and I've tried to find references to it but it doesn't seem like any of the old commands (cphaconf cluster_id get or cphaprob mmagic) seem to work in R80.40 anymore so it's somewhat difficult to verify.

If anyone had any debugging tips or ideas as to why this is happening I'd really appreciate your insight!

 

0 Kudos
6 Replies
This widget could not be displayed.