Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Rodrigo_Silva
Contributor

Delivering reserved IP in the ipassignment file to other users

Jump to solution

Hello everyone,
I'm having problems with the ipassignment file.
I created the IP reservation for some users, but other users are receiving the reserved IP, and when users with reserved IPs will connect, it gives an error message saying that it was not possible to obtain an IP address.
Does anyone have any ideas how to solve this problem or where to see ipassignment logs?
Thank you in advance.

IP.png

2 Solutions

Accepted Solutions
Rodrigo_Silva
Contributor

The configuration was correct according to sk33422.
I had reserved random IPs, and according to my support team I was instructed to reserve IPs at the beginning or end of the range, and replace the gategay address with *.
My setup looks like this and apparently it's working right now.

################################
### Gateway Type IP Address User Name ###
################################
* addr 172.16.0.254 user1
* addr 172.16.0.253 user2
* addr 172.16.0.252 user3
* addr 172.16.0.251 user4
* addr 172.16.0.250 user5
* addr 172.16.0.249 user6

Thank you all

View solution in original post

0 Kudos
Rodrigo_Silva
Contributor

We continue to have the same problem.
According to sk116603 reserved ips cannot be in the range delivered in office mode.
We created a new range for reserved ips and now we have no more problems.
Thank you all

View solution in original post

0 Kudos
10 Replies
MartinTzvetanov
Collaborator

Print a sample of your ipassignment.conf 

G_W_Albrecht
Legend
Legend

If you have carefully follower configuration examples in Remote Access VPN Administration Guide R80.20 p.58ff, logs will be helpfull:

In clients VPN Options > Advanced Tab, enable Logs. Replicate the issue on the client successfully noting the exact time and click on Collect Logs. Wait a while and the compressed logs will be shown. Disable logging and review the logs in trac.log e.g. using search for GW IP. Full debugs are found here: sk95486: How to debug Endpoint Client connection issues

 

CCSE CCTE SMB Specialist
PhoneBoy
Admin
Admin

If you assign a given user an IP address make sure it is impossible for any other user to be assigned this address.
This means making sure that IP is NOT in the general pool of users.

Rodrigo_Silva
Contributor

The configuration was correct according to sk33422.
I had reserved random IPs, and according to my support team I was instructed to reserve IPs at the beginning or end of the range, and replace the gategay address with *.
My setup looks like this and apparently it's working right now.

################################
### Gateway Type IP Address User Name ###
################################
* addr 172.16.0.254 user1
* addr 172.16.0.253 user2
* addr 172.16.0.252 user3
* addr 172.16.0.251 user4
* addr 172.16.0.250 user5
* addr 172.16.0.249 user6

Thank you all

View solution in original post

0 Kudos
MartinTzvetanov
Collaborator

Capture.JPG

What is your config?

0 Kudos
Rodrigo_Silva
Contributor

 

ipassignment.JPG

 

ip2.JPG

 

0 Kudos
Christian_Koehl
Contributor

You are doing radius authentication. Have you check the office mode with a local user on the firewall before switching to radius? If not, does it work with a local user?

0 Kudos
Rodrigo_Silva
Contributor

I haven't tested it with a local user, only via radius.

0 Kudos
Rodrigo_Silva
Contributor

We continue to have the same problem.
According to sk116603 reserved ips cannot be in the range delivered in office mode.
We created a new range for reserved ips and now we have no more problems.
Thank you all

View solution in original post

0 Kudos
Jasvijay
Explorer

Had same issue, but creating a new pool for a handful of users with reserved IP was not an option for us, What I ended up doing is using the group and range command to ensure users whose ip we dont care about are picked from the range(ex. 192.168.0.1-192.168.0.200) and the reserved IP's are set per user starting from back 254..253... and so on.

# Miami          range  100.107.105.110-100.107.105.119/24        Finance 

 

0 Kudos