Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Florian_Heindl
Contributor

web_api_show_package.sh not working since Management Upgrade to R80.40

Hello,

since we updated our Management System to R80.40 we can't generate an policy html export via web_api_show_package.sh

R80.40 uses version 2.0.5 of this tool.

 

Within the DEBUG Informations I get following error message:

 

1/22/21 8:01 AM com.checkpoint.mgmt_api.examples.MyLogger.warning()WARNING]: Failed to execute command: show-vpn-communities-star. Message: 'Runtime error: com.checkpoint.objects.classes.dummy.CpmiSlimFwLogPolicy incompatible with com.checkpoint.objects.classes.dummy.CpmiLogPolicy'. Status Code: '400'


[1/22/21 8:01 AM com.checkpoint.mgmt_api.examples.MyLogger.severe()SEVERE]: Failed to run show-packages command. Aborting. Message: 'Runtime error: com.checkpoint.objects.classes.dummy.CpmiSlimFwLogPolicy incompatible with com.checkpoint.objects.classes.dummy.CpmiLogPolicy'. Status Code: '400'


[1/22/21 8:01 AM com.checkpoint.mgmt_api.examples.ShowPackageTool.logoutReportAndExit()INFO]: Script stopped running due to severe error!

 

Has anybody the same problem? Perhaps 2.0.6 would help? If 2.0.6 would help were can I get a pre compiled version for R80.40?

 

Thanks

 

Regards

 

 

Florian

0 Kudos
Reply
3 Replies
Omer_Kleinstern
Employee
Employee

Hi Florian,

 

The issue was fixed in R80.40 JHF take 91 (PRJ-16979).

 

Thanks,

Omer

0 Kudos
Reply
Florian_Heindl
Contributor

Hello Omer,

 

thank you for that great news.

 

How stable is this take for production environment? Should I install them to fix or is it better to wait for the next "stable" 🙂 take?

 

Regards

 

Florian

0 Kudos
Reply
Omer_Kleinstern
Employee
Employee

Take 91 is still considered as "Ongoing", if you prefer to stay on a GA take you can wait for the next GA or contact TAC for a private fix.

0 Kudos
Reply