Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Bernhard_Sayer
Contributor

Syntax "mgmt_cli set network" with "nat-settings"

Jump to solution

Hi!

I could not find the correct syntax to configure a network "behind gateway nat". I tried the following without luck:

mgmt_cli set network name "guest-lan" nat-settings hide-behind gateway install-on "Vienna-Branch"
mgmt_cli set network name "guest-lan" nat-settings hide-behind "Vienna-Branch" install-on "Vienna-Branch"
mgmt_cli set network name "guest-lan" nat-settings "hide-behind gateway" install-on "Vienna-Branch"
mgmt_cli set network name "guest-lan" nat-settings "hide-behind Vienna-Branch" install-on "Vienna-Branch"
mgmt_cli set network name "guest-lan" nat-settings "hide-behind gateway Vienna-Branch" install-on "Vienna-Branch"  

Has anyone already configured this?

Thanks,

Bernhard

1 Solution

Accepted Solutions
Bernhard_Sayer
Contributor

Luckily i found the correct syntax:

 mgmt_cli set network name "guest-lan" nat-settings.auto-rule "true" nat-settings.hide-behind "gateway" nat-settings.install-on "Vienna-Branch"

View solution in original post

2 Replies
Bernhard_Sayer
Contributor

Luckily i found the correct syntax:

 mgmt_cli set network name "guest-lan" nat-settings.auto-rule "true" nat-settings.hide-behind "gateway" nat-settings.install-on "Vienna-Branch"

View solution in original post

Robert_Decker
Employee Alumnus
Employee Alumnus

This is from API reference guide - 

https://sc1.checkpoint.com/documents/latest/APIs/index.html#gui-cli/set-network~v1.1

Look at the "nat-settings" parameter.

As a rule, when you have an object as a parameter, you use the "object.object-field" syntax.

Robert.