Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
RobertZdunek1
Explorer

SmartConsole MFA - Google Authenticator

Hi,

We are trying to implement MFA login to SmartConsole with Google Authenticator but with no luck. Everything when smooth with Gaia Portal, but SmartConsole fails to authenticate (the same configuration is applied to both). 

Best regards,

RZ

0 Kudos
6 Replies
_Val_
Admin
Admin

Would you please share more details? Specifically, configuration you have on both, and the version in use?

0 Kudos
_Val_
Admin
Admin

Also, look to this post and the document attached there, to check you are configuring it the same way: https://community.checkpoint.com/t5/General-Topics/MFA-with-Google-Authenticator/td-p/39456

 

0 Kudos
RobertZdunek1
Explorer

That's the manual I used when configuring MFA in Gaia Portal and also SmartConsole.  Gaia works fine, SmartConsole (R80.40) not. When trying to authenticate using Password+Code in the Password field in SmartConsole I get:

 radiusd(pam_google_authenticator)[11610]: Invalid verification code for xxxx
0 Kudos
_Val_
Admin
Admin

Got it. @Vladimir what do you think? It is your setup 🙂

0 Kudos
Vladimir
Champion
Champion

There were updates in the thread by members adopting my solution describing some changes to the freeradius configuration dependent on Ubuntu releases. Were those taken into consideration?

I may have to re-run this setup on R81.10 and current Ubuntu LTS at some point. Looks like it may still be relevant for some folks.

0 Kudos
_Val_
Admin
Admin

I would start with looking into the actual radius requests and answers between SMS and the Ubuntu here.

0 Kudos