Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Lijo_mathai
Contributor

SMART CLI greyed out

Hi Checkmates,have anyonr faced this, SMARTCLI in my SMARTCONSOLE is greyed out. Is there any configuration change need to enable thisSMARTCLI.PNG

0 Kudos
7 Replies
Tal_Paz-Fridman
Employee
Employee

Hi

This might be caused if the Management API service is down or not running properly.

On the machine run the command api status to check the status of the service.

To restart it run api restart and check that it started successfully.

Login again using SmartConsole - the Command Line button should be enabled.

If the API service is not started after api restart or even after reboot of the machine please open a ticket.

HTH

Lijo_mathai
Contributor

This looks like some issue with my laptop. I guess the HIPS might be blocking the access to the CLI portal. When i tried from the Jump server it worked fine.

0 Kudos
rrbranco
Contributor

Does the user has permission to open Smart Console Command Line ?  

Check 

https://sc1.checkpoint.com/documents/R80.40/SmartConsole_OLH/EN/Content/Topics-OLH/ZkGmr2zRwXBYyz4z_...

"

...

Open Shell - Use the SmartConsole CLI to run commands.

...

"

 

0 Kudos
the_rock
Authority
Authority

I see point @Tal_Paz-Fridman makes, though in my opinion, if api was the issue, dashboard would probably never open in the first place. When did you first notice this?

Andy

0 Kudos
PhoneBoy
Admin
Admin

Not necessarily, since one does not need to have API access enabled to use SmartConsole.

0 Kudos
the_rock
Authority
Authority

Interesting...thats not my experience personally.

0 Kudos
the_rock
Authority
Authority

I recall few times when running api status, it would show api stopped and dashboard would never come up, but as soon as I would do api start, all worked fine.

Andy

0 Kudos