Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
HeikoAnkenbrand
Champion
Champion

R81 SmartConsole config file doesn't work

I have a problem with the SmartConsole config file and version R81.

Is this no longer supported from R81 or is this a bug?

I'll try the following:

 

"C:\Program Files (x86)\CheckPoint\SmartConsole\R81\PROGRAM\SmartConsole.exe" -p D:\SmartConsoleP.xml

 

And the file SmartConsoleP.xml for the SmartConsole login:

 

<?xml version="1.0" encoding="utf-8"?>
	<RemoteLaunchParemeters xmlns:xsi="http‌‌/www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http‌‌/www.w3.org/2001/XMLSchema">
		<Username>admin</Username>
		<ServerIP>x.y.z.w</ServerIP>
		<DomainName></DomainName>
		<ReadOnly>False</ReadOnly>
		<CloudDemoMode>False</CloudDemoMode>
		<Password>this is secret</Password>
	</RemoteLaunchParemeters>

 

PS:
This works without problems with version R80.10 - R80.40.

 

6 Replies
Dima_M
Employee
Employee

Hi Heiko,

Thanks for reporting, we're already working to fix this issue. If you would like to get a private HotFix, please submit a Service Request.

HeikoAnkenbrand
Champion
Champion

Thanks

0 Kudos
Reply
randolchen
Explorer

Hi,

Same here, I just ran into this. I tried the latest version R81 (81.0.9500.549) as of today (Build 549 published 2021-02-04)  but the problem persists. Is any fix available? I just opened a SR just in case. Maybe DEVs updated something on the Syntaxis of the XML.

@HeikoAnkenbrand by the way, just in case you need it... I realized that R80.x didnt recognize the ReadOnly option (<ReadOnly>True</ReadOnly>), after a very long testing session I figure it out this (<IsReadOnly>1</IsReadOnly>) as a working workaround to connect Read Only "R80.x".

Thanks.

RChen
Arne_Boettger
Contributor

Thank you for that information. Unfortunately, our request for a private Hotfix for R80.30 was denied and we were told to monitor the release notes of SmartConsole for a fixed version.

 

best regards, Arne

0 Kudos
Reply
ottawacanada150
Advisor

Yes, I have the same issue as well...glad they are working on the fix.

0 Kudos
Reply
Sagivw
Employee
Employee

Hi Heiko,

As Dima_m mentioned, we are working on a fix- It is important to state that this is not actually an issue, but that the feature was adjusted so that you can no longer use it with the password in clear text within the XML file but using an SSO token instead. (duo to Security reasons) 

It has been integrated as so in the latest SC build for all versions- we are currently integrating the fix that will allow you to use it with clear text password for R80.30 and R80.20 (no ETA at the moment, still under testing) as for R80.40 and above- according to my understanding, it will not be reinstated.

Official documentation about all of this is inbound.

 

Hope that clarifies things 🙂