Create a Post
Showing results for 
Search instead for 
Did you mean: 

R80.10 SmartConsole hangs

Sorry to hijack this thread but just wanted to mention that SmartConsole isn't very stable here. From time to time it hangs like that:

The program SmartConsole.exe version stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
Process ID: a04
Start Time: 01d3d2e729908720
Termination Time: 32
Application Path: C:\Program Files (x86)\CheckPoint\SmartConsole\R80.10\PROGRAM\SmartConsole.exe
Report Id: 64c7780f-5b6d-403b-9af6-19ec77a760df
Faulting package full name:
Faulting package-relative application ID:

And yesterday even built-in whois caused an exception:

Faulting application name: whois.exe, version:, time stamp: 0x3c3e3838
Faulting module name: KERNEL32.DLL, version: 10.0.16299.15, time stamp: 0x744765ce
Exception code: 0xc0000409
Fault offset: 0x00053da3
Faulting process id: 0x4f0
Faulting application start time: 0x01d3d222f4634412
Faulting application path: C:\Program Files (x86)\CheckPoint\SmartConsole\R80.10\PROGRAM\lvwhois\whois.exe
Faulting module path: C:\WINDOWS\System32\KERNEL32.DLL
Report Id: 7b64e229-9652-4216-8728-a48c101afe3a
Faulting package full name:
Faulting package-relative application ID:

One time SmartView crashed:

Application: SmartViewMonitor.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
at <Module>.WinMainCRTStartup()
at <Module>.SmartConsMain()

There is a GuiDBedit crash also:

Faulting application name: GuiDBedit.exe, version:, time stamp: 0x58e8157a
Faulting module name: GuiDBedit.exe, version:, time stamp: 0x58e8157a
Exception code: 0xc0000005
Fault offset: 0x0000b73b
Faulting process id: 0x6d8
Faulting application start time: 0x01d3d0fcf7dcc383
Faulting application path: C:\Program Files (x86)\CheckPoint\SmartConsole\R80.10\PROGRAM\GuiDBedit.exe
Faulting module path: C:\Program Files (x86)\CheckPoint\SmartConsole\R80.10\PROGRAM\GuiDBedit.exe
Report Id: a97aa928-df7f-47b3-b33d-99f057945d11
Faulting package full name:
Faulting package-relative application ID

And, believe me I ain't doing anything fancy. 

Windows 10 x64, latest updates.

25 Replies

Hi, I branched out your complaint since the original thread was about R77.30 and R80.10 is entirely different UI and backend.

For this kind of problems I strongly suggest that you open a Check Point Support ticket so that Check Point Support will be able to investigate this fully and provide a maintrain fix for the benefit of all of our users.

I will do that. Just want to have the time to confirm it mostly happens when blocking operation makes GIU non-responsive thus causing Windows internal process monitor to report it as hanged process. At least it looks like that to me.


I can reproduce this crash every time now by trying to Install Policy and select View Changes from there. I don't know but it might be connected to the change I just did. I am going to open SR and wait for 2 hours to contact me. Then I need to install policy and it may not happen again. If you want to investigate it on site be quick Smiley Happy


Are you using R80.10 SmartConsole Build 029 ?

Yes, it is build 029. I've opened SR and together with TAC we tried to investigate it. But once we installed the policy we could no longer reproduce this issue. So, we decided to close the SR and re-open it if it happens again. 


That is a good way to cope with that 😉

Well, I would dive into the stack trace and do code review in an attempt to discover what went wrong but this is just me and I guess this is a minor issue not worth to forward to developers for further investigation. 

send me the SR.... 

SR 3-0117941101

0 Kudos

Any findings on this ? It is doing it again at the moment. Notice in the top right corner summary about changes is missing. When ti does that a crash will occur for sure.

From some reason I can't find that case.. either you have a typo or my account can't access this. Can you send me a private message with more details from the case, some other texts that I can paste to find?

I tried to send you private message but it is telling me I can only send to friends or smthg like that. May be I am doing something wrong. Can you try to message me ?

0 Kudos

Correct, PMs are only allowed to someone if they are following you.

I have provided Tomer Sole‌ your email address also so he can continue an offline conversation with you.


Did the issue resolve? I am facing the same issue.

0 Kudos

If I recall correctly it happened to me last week with the latest SC build. So probably not fixed yet. 

But live it. Smiley Happy SC crashes on many occasions. For example if connection to management server is suddenly lost...

0 Kudos

Hi, we did not get the files from you, therefore were not able to handle the case.

I want to explain our stance with GUI crashes in R80 and above:

1. Any customer who chose to share anonymous data with Check Point, in case SmartConsole crashes, the crash report gets automatically sent to Check Point servers. From there, an automatic system checks whether the bug scenario has been reproduced and fixed before for that particular version jumbo hotfix. If it wasn't, R&D analyze the problem, fix it, and publish it for the next available Jumbo Hotfix, as well as port it for the other Check Point releases. 

2. It is always preferred to interact with Check Point Support if you want to have the problem fixed. Support cases are opened at Support, Support Requests, Training, Documentation, and Knowledge base for Check Point products and .... This is our best way of tracking progress with software bugs. 

3. We will fix any SmartConsole crash (of a supported version) if we get the task for it through Check Point Support or with the automatic crash reporter cloud service.

0 Kudos

An update: we received a similar crash report with that reproduction scenario from other customers, and will issue a fix for that view in the next R80.10 Jumbo Hotfix. It was also fixed for R80.20 and R80.20.M1 previously. I am not sure if that is 100% the same scenario as yours though, so it will not hurt if you can attach the files.

Yeah, I remember files were no longer on the management server or something like that. Either way I do not blame CheckPoint for anything. I opted not to open SR for this type of crash anymore relaying on the mechanism of sending automatic crash reports (1). Which I did.

At the moment it is very easy to reproduce it. Just have no changes made to the policy. Open policy install dialog and click "View Changes" link. Enjoy the crash. I am sure this is some kind of GUI event handling problem that is probably already fixed in the next R80.10 Jumbo Hotfix. Not a big issue.

The crash when connection to SMS is suddenly lost happened today and there was no dialog to ask me to send diag data. App just closed. I will try to reproduce it later today.

0 Kudos

You are using newest Check_Point_SmartConsole_R80_10_jumbo_HF_B073_Win ?

0 Kudos

Yes, I do. Build 991140073

0 Kudos

Same issue has seen! Do CP really have a "patch" for this since it occurs very often and xcross the board or this is more likely case-by-case? thx

0 Kudos

Make sure you're working with the TAC on this.

How To Open a Case with TAC and/or Account Services

I have not seen widespread reports of this issue, so it may be something environment specific we need to look at.

0 Kudos

Not all crashes are created from the same reason. Steps are different. The hanging is the outcome, not the reason. 

This is why we ask for ticket per problem. And if opening a support ticket is difficult, please share your experience with that as well. 

I do not quite remember because I already migrated to R80.20 but right before that I do not recall having any issues with Smart Console stability in its latest version at that time.

I second Dameon that it might be a specific case that TAC needs to investigate. 

0 Kudos

I don't know if this was now already fixed, but I face this issue multiple times a day with a multi domain Smart Dashboard R80.10 (SmartConsole 991149956). The very strange behaviour is also, that some domains in our multi domain environment I can connect without any issues and other's hangs. CPU usage of this SmartDashboard process on my PC is rising to a higher level (approx. 60%) and the SmartConsole just hangs so I have to kill it in the Task Manager. But if I start the SmartDashboard as Administrator then I can open all Policies/Dashboards without any problems. Maybe the Dashboard has for some unknown reasons some Windows access problems? - SmartDasboard is running on Windows 10 on my PC. I don't know if this issue happens also on Windows 8.x or Windows 7?




0 Kudos