Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
joe-h
Explorer

Central Deployment Tool (CDT) v1.9.3 - - <send_email to="me@gmail.com" ...

Jump to solution

Central Deployment Tool (CDT) v1.9.3 - - <send_email to="me@gmail.com" subject="mysubject body="mybody" />

Having an issue with send_email
Testing in lab for now and trying to use gmail - port 587 with authentication username and password and TLS (this all works with Smart Event Server)
Everything I have tested in my CDT deployment plans work beautifully and now I would like the email to work for notification
I have not found anywhere to configure parameters for email other than the username and server
Have beat my head against the wall long enough and even beat CP's head against the wall (they are researching)
But if anyone has any ideas or has this working in the current version, I would be very appreciative

MDS R80.40 T139
set mail-notification username me@gmail.com
set mail-notification server smtp.gmail.com

My deployment plan is ... (keep in mind that all other functions have been tested and work - this plan is just email)
-------------------------

[Expert@mds10:0]# cat testemail.xml
<?xml version="1.0" encoding="UTF-8"?>
<CDT_Deployment_Plan>
<plan_settings>
<name value="Upgrade-To-R8040-Plus-Take139.xml" />
<description value="Upgrade-To-R8040-Plus-Take139.xml" />
<update_cpuse value="false" />
<connectivityupgrade value="false" />
</plan_settings>


<!-- Create a log -->
<log level="NORMAL" value="Finished installing major upgrade." />

<!-- Send an email -->
<send_email to="me@gmail.com" subject="mysubject" body="mybody" />


</CDT_Deployment_Plan>

 

The error I get is ...
-------------------------

An error has occurred in stage Send Email of machine gw31:

Error code 72 - Failed to send an e-mail.

Additional Information:
-----------------------

************************************************
Mail Message Failure
Error code 74 - Failed to send an e-mail message. Make sure that the mail server is properly configured in Gaia and that mail address is valid.

Details:
--------

Command Summary:
Command = /bin/cat cdtMailTemplate | /usr/sbin/sendmail -t --host=smtp.gmail.com -f CDT-Do_Not_Reply@checkpoint.com
Return code = 71
Output = sendmail: cannot create socket: Address family not supported by protocol
sendmail: could not send mail

0 Kudos
1 Solution

Accepted Solutions
Boaz_Orshav
Employee
Employee

Unfortunately sending mail over the non-default port is not supported

Sorry

View solution in original post

(1)
5 Replies
_Val_
Admin
Admin

It looks to me, gmail does not want to talk to you via smtp. Encryption/Authentication maybe?

0 Kudos
joe-h
Explorer

Thanks and right but I was not wanting to use port 25

"Testing in lab for now and trying to use gmail - port 587

I have not found anywhere to configure parameters for email"

0 Kudos
PhoneBoy
Admin
Admin

@Arik_Ovtracht can someone on your team comment?

0 Kudos
Arik_Ovtracht
Employee
Employee

Actually it's in @Boaz_Orshav 's team.

0 Kudos
Boaz_Orshav
Employee
Employee

Unfortunately sending mail over the non-default port is not supported

Sorry

(1)