Create a Post
Showing results for 
Search instead for 
Did you mean: 

Activating Identity Awareness R80 gateway with Active Directory can obtain user list

Hi, im trying to activate my identity Awareness blade on R80 gateway, in the wizard the connection with my AD result ok, but when Im trying to create a Access Role requesting a list of users of the domain controller, it doesn't  work.

When I use the test_ad_connectivity -x -o my_test2.txt -s -w command on expert mode, I can see these results:

[Expert@gwr801:0]# cat my_test2.txt
        :status (SUCCESS_WMI)
        :ldap_status (LDAP_OPERATIONS_ERROR)
        :wmi_status (ADLOG_SUCCESS)
        :timestamp ("Fri Nov 23 10:37:19 2018")

Using another diagnostic commands, the output shows connection with the active directory, in fact I can observe data for machines on =the domain an users of certainf OUs. but in the Securty Management I can not obtaing the user list, to create access roles based rules.

other ouptputs:

[Expert@gwr801:0]# adlog a dc
Domain controllers:
Domain Name               IP Address                Events (last hour)   Connection state
============================================================================================================                  167                  has connection
Ignored domain controllers on this gateway:
No ignored domain controllers found.
[Expert@gwr801:0]# adlog a q a
ip: --> Users: Ernesto Cabello (; fortilab (;
ip: --> Machines:;
ip: --> Machines:;
ip: --> Machines:;
ip: --> Machines:;
ip: --> Users: Gabriel Salcedo (;  --> Machines:;
ip: --> Users: Angel Garcia (;  --> Machines:;
ip: --> Users: Antonio Rodriguez (;  --> Machines:;
ip: --> Users: Javier Orejarena (;  --> Machines:;
ip: --> Users: Angelica Rangel (;  --> Machines:;
ip: --> Users: Arquimedes Gardie (;
ip: --> Users: Ludexi Ortega (;  --> Machines:;
ip: --> Users: Yeritson Pernia (;  --> Machines:;
ip: --> Users: Janeth Laguado (;  --> Machines:;
ip: --> Machines:;
ip: --> Machines:;
I can see detailed information of the domain via shell, but not on the Security management, 
thanks for anyone help me. 
9 Replies

Hi Antonio,

Please make sure that your PC in which you are opening smart console should be also in same domain.

0 Kudos

First, there is no such gateway version R80: you are either using R80.10 or R80.20.

That said for this question it's not terribly relevant.

One relevant question: are you using Identity Collector or ADQuery?

Your gateway shows the users it has been told about by the AD server.

A seperate LDAP lookup must be performed on each user (and management) to get the groups associated with each user.


thank you Dameon, in fact, R80.10 its the release what I was working on. I activate the ip forwargind on my PC host for the lab and try again, and obtain successful results, listing the users, machines and othe info from the domain controller. But I still seeing the error message LDAP_OPERATIONS_ERROR


the error message, is obtained when I run the script $FWDIR/bin/test_ad_connectivity on the gateway, and when I do the same on the SC, obtain a general error.

Right now, I can go ahead with my lab environment, we can build rules on the Url Filter Layer based on Identity captured from the AD. When I procced to the production deployment I probably need checkpoint support if the behavior persist on the real configuration. 

thanks to all

0 Kudos

Check $FWDIR/log/test_ad_connectivity.elg to see if you can see more details.


You need to allow your workstation IP address to be allowed somewhere (LDAP). SmartConsole is using your internal IP of desktop.

CLI of mamagement is using IP of management server.

Kind regards,
Jozko Mrkvicka
0 Kudos

The SmartConsole machine is not connecting to the AD server anymore in R80+, only the management server and the gateway are doing this now.

In a Multi-domain environment the MDS and Domain server are both making connections (at least they were in R80.10, I need to see about this in R80.20).

Regards, Maarten

thanks for your support, really, we solve the issue, activating the IP forwarding on my PC, to give connection from the SC to the AD. However, when I run the test, right now the SC list the user for me, to add access control rules, but the test_connection script still sayng the same message, LDAP OPERATIONS ERROR


This is probably because the -w option "Specifies that only the WMI connectivity test (no LDAP) should be performed".  LDAP worked for me without this option or with -l 

 test_ad_connectivity -x -o my_test2.txt -s -l

0 Kudos


Epsum factorial non deposit quid pro quo hic escorol.

Upcoming Events

    CheckMates Events