Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

cluster xl 80.40 - trouble with external dns querys

Hi i have upgraded a Cluster XL to 80.40

this cluster works only as firewall (NGTP or NGTX isn't active)

in the smartconsole is all green.

 

dns query from internal to external doesn't work when secure xl is enabled.

if i disable secure xl the dns querys are working.

 

have anyone the same problem?

how can i solve this? (have to wait for a new hotfix?)

 

thanx all, regards

flo

6 Replies
Highlighted
Admin
Admin

If disabling SecureXL "solves" a problem, it's a bug.
Open a TAC case, please.
Highlighted

I had the same problem. But there is a solution to bypass the DNS server IP. You can bypass SecureXL (green flow in the picture) as described. This will use the F2F path instead of the acceleration path. 

Screenshot_20200308-183104_Edge.jpg

How to disable SecureXL for specific IP addresses? Edit the relevant table.def file, define the DNS Server IP addresses, whose traffic should not be accelerated. You can find more on this topic in this sk104468.

More read here:
- R80.x - Performance Tuning Tip - Control SecureXL / CoreXL Paths
- R80.x - Security Gateway Architecture (Logical Packet Flow)

 

Tags (1)
Admin
Admin

Obviously that's a workaround, but we should find out why we need to disable SecureXL for this.
0 Kudos
Highlighted

Experiencing the same issue after upgrading a Cluster to R80.40.

 

Interestingly the DNS traffic goes through 2 x Clusters and the issue goes away after disabling SecureXL on one of them.

 

We are using a bind DNS server, same issue using forwarders or root hints.

 

Looks like the DNS reply packet is sent twice on the egress interface from the gateway, but is never visible in a tcpdump on the DNS server itself.

0 Kudos
Highlighted

Also managed to get this working by enabling the IPS blade (previously had firewall + IA + Mobile access only).

 

fwaccel conns now shows the inbound and outbound connections with the 'S' flag (PXL enabled).

Highlighted

@chris_denham 

works

but it's only a workaround.

any updates?

regards

0 Kudos