Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
fsanchezwtu
Explorer

MGMT9000 Couldn't connect to server

Jump to solution

Hello Everyone.
This is my first deployment of R 81.10 (Previously 77.30) and I'm feeling the changes.

I have 2 problems:

 

1 -  I'm trying to add host from CLI using the following line:

"add host name host1 ipv4-address 192.168.2.100"

Everything seems to work fine, to complete i use "Save Config" to install Policies but nothing happens.
Is there another way to install policies from CLI that i don't know?

2 - Reading the documentation i found that i need to use the API.

But when i try to login into it i get the following error

FW1> mgmt login user admin
Enter password:
MGMT9000 Couldn't connect to server

 

I don't know what else can i do?

 

0 Kudos
1 Solution

Accepted Solutions
Ruan_Kotze
Advisor

Thanks - did you change your port to port 4434 (you are running a custom port)

When running mgmt_cli commands add '--port 4434'

View solution in original post

0 Kudos
5 Replies
Ruan_Kotze
Advisor

Hey there,

What's the output of the "api status" command?

0 Kudos
fsanchezwtu
Explorer

This are the results:

 

API Settings:
---------------------
Accessibility: Require all granted
Automatic Start: Enabled

Processes:

Name State PID More Information
-------------------------------------------------
API Started 10626
CPM Started 10626 Check Point Security Management Server is running and ready
FWM Started 10298
APACHE Started 10234

Port Details:
-------------------
JETTY Internal Port: 54321
JETTY Documentation Internal Port: 62998
APACHE Gaia Port: 4434 (a non-default port)
When running mgmt_cli commands add '--port 44 34'
When using web-services, add port 4434 to the URL

Profile:
-------------------
Machine profile: Small Medium env resources profile
CPM heap size: 1280m

Apache port retrieved from: httpd-ssl.conf


--------------------------------------------
Overall API Status: Started
--------------------------------------------

API readiness test SUCCESSFUL. The server is up and ready to receive connections

Notes:
------------

0 Kudos
Ruan_Kotze
Advisor

Thanks - did you change your port to port 4434 (you are running a custom port)

When running mgmt_cli commands add '--port 4434'

0 Kudos
fsanchezwtu
Explorer

It was this! 

Adding the port to the end i solved.

 

0 Kudos
the_rock
Champion
Champion

Can you run cpwd_admin list and send? Also, below is command you can try from cli:

https://sc1.checkpoint.com/documents/latest/APIs/#cli/install-policy~v1.8%20