Create a Post
Showing results for 
Search instead for 
Did you mean: 

DHCP server is not active

This issue is solved, I am posting it in case anyone else is experiencing the same problem.

One of our customers configured a simple DHCP Relay on a standalone CP3100 gateway running Gaia R77.30, using the new services as per sk104114. Everything was set up correctly, but the dhcp relay was not working. The incoming dhcp requests have been accepted from the clients, but nothing has been forwarded to the relay server, tcpdump did not show any bootp packets exiting on the configured interface. We have ruled out any NAT, policy or routing issues. At this point of troubleshooting we have not done any bootp traces or kernel debugs yet (although it would have been useful). 


We found this:

> set bootp interface eth2 on
> set bootp interface eth2 primary x.x.x.x wait-time 40 on
> set bootp interface eth2 relay-to y.y.y.y on
> save config
> show bootp interface eth2
BOOTP: Feature not enabled on eth2


But in the actual configuration we could see the setting enabled (routed.conf):

bootpgw on
interface eth2 maxhopcount 35 waittime 40 primary x.x.x.x relayto { 
host y.y.y.y; 



[...] xpand[4962]: admin localhost t +routed:instance:default:bootpgw:interface:eth2:waittime 40 
[...] xpand[4962]: Configuration changed from localhost by user admin 
[...] routed[5097]: bootpgw (bootpgw_detect_listener_mode): Relay agent will listen on because DHCP server is not active 
Jun 3 16:06:01 2019 b-schul-ha1 routed[5097]: task_reconfigure reinitializing done 


Only a reboot solved the issue, a cpstop/cpstart was not enough.

(Reference found in this reddit post.)



0 Kudos
1 Reply

This occurs sometimes. Just restart routed.
(sk97638 tells how)
0 Kudos


Epsum factorial non deposit quid pro quo hic escorol.

Upcoming Events

    CheckMates Events