Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Ahmadhr
Contributor

login session goes to 'disconnect' mode after timeout

Jump to solution

hi everyone, 

 

i have noticed that when i login to get the sid, the session goes to 'disconnect' mode after session-timeout and never gets released.

in fact that is very random, out of 10 login session, 4 of them gets released, and 6 of them stays 'disconnect'ed. 

 

https://<myfw>/web_api/login

{
"user" : "myuser",
"password" : "mypass",
"domain": "Domain-Name",
"session-timeout": 60,
"session-name": "PostMan"
}

 

do you know how i can fix this issue? 

0 Kudos
1 Solution

Accepted Solutions
Chris_Atkinson
Employee
Employee

Please check if sk169072 is related to your case.

View solution in original post

6 Replies
Chris_Atkinson
Employee
Employee

Please check if sk169072 is related to your case.

View solution in original post

Ahmadhr
Contributor

thanks so much it seems related, i will check with my firewall expert on this secure knowledge, to see if he wants to get the hotfix or wait for the R81

0 Kudos
JozkoMrkvicka
Leader
Leader

Do you know why you are reaching session-timeout? Are there some heavy API calls lasting for more than 60 seconds ? If yes, you can increase session-timeout to higher value (1 hour - 3600 seconds) and see if this will help.

Kind regards,
Jozko Mrkvicka
Ahmadhr
Contributor

the session times out when there is no activity on the session. which is fine, but i would like it to get released from the manager. 

0 Kudos
JozkoMrkvicka
Leader
Leader

If there is no activity then logout from the session using sid which was used durin login. Do not wait till session timeout.

What version and Take you are running ?

 

Kind regards,
Jozko Mrkvicka
0 Kudos
Ahmadhr
Contributor

Jozko, 

it doesnt matter if i logout or let it to timeout, it still stays at disconnected and wont get released. i am running R80.30

0 Kudos