Create a Post
Showing results for 
Search instead for 
Did you mean: 

Current bugs I have found with management API

As you requested Robert Decker here are the bugs I have found so far. I have attached examples.

One I have already raised in the following thread.

How do you remove an IP Address from host using API . For this example it shows me trying to clear the IPv6 address using both null and empty string. I have tried others as well but none work.

Another is on set commands like set-host sometimes if you are using the UID to identify the object to be updated you will get errors (Most times it works). However make the exact same call using the name and it works. For this example I attached, it shows me trying to clear the assigned groups, first by using Name which works, then using UID which fails.

Lastly when trying to set date and time value like the end value on a Time object, if you use posix format it changes the value by like 40 seconds. Using ISO8601 works fine. In the attached example for this, I am creating a new time object with a End date and time set, it shows first working with ISO8601 but then using posix it changes the time by 40 seconds.

3 Replies

Thanks Tim,

We will go over and check, and will fix as needed.


0 Kudos

I have found another bug when trying to clear all tags from a host. Doing it the same way as clearing all groups by sending empty array ([ ]) doesn't work. I have also tried empty string (""), which produces an error and null which does same as empty array, nothing. I have attached ClearTags.txt which shows what I mean with empty array.


0 Kudos

Hi Tim, would you mind opening separate threads for each issue? I'm thinking other users would like to successfully google a thread that has their same problem, and this thread's title probably won't help them... 

0 Kudos


Epsum factorial non deposit quid pro quo hic escorol.

Upcoming Events

    CheckMates Events