Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
toubar
Explorer

Checkpoint - task from show-changes API command fails

I would like to use the show-changes command but it fails with "The show-changes operation failed". The error does not tell me why it failed so I am not able to troubleshoot. 

 

I did some experimentation. And here are the results. Let's say I have 90 changes in total during the past 30 days. If I run the show-changes command with the body: 

 

{
    "from-date": "2021-08-16",
    "to-date": "2021-09-15",
    "limit": 100
}

 

 

 Then I use the returned task-id to get the changes, I get:

 

{
    "task-id": "<<TASK_ID>>",
    "task-name": "Show Changes",
    "status": "failed",
    "progress-percentage": 100,
    "progress-description": "The show-changes operation failed",
    "suppressed": false
}

 

 ---

So I tried to limit each task to 20, then use the offset to get succeeding changes. This led to the first task succeeding, and the later task(s) failing with the same returned body as the one above.

 

So, I am not able to get the entire changes made during the period.

 

Please assist.

0 Kudos
1 Reply
PhoneBoy
Admin
Admin

You may try restarting the management server.
Otherwise I recommend a TAC case. 

0 Kudos