Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
MaxPower
Explorer

Compliance check forcing https?

First off, I apologize in advance as this is my first post here and my knowledge of Checkpoint leaves a lot to be desired. I've only been using and administering it for a couple of months.

We have a situation where our developers do a lot of local testing, so they're constantly accessing localhost while VPNed in using Checkpoint, which seems to be forcing them to use https rather than http. This is a bit of a hassle for them and we'd like to see if we can solve this on the Checkpoint side rather than having them set up https for all of their local testing. They can currently get around this by using incognito mode, but this also isn't ideal.

We tried having them modify their HSTS settings in Chrome (their browser of choice) and it'll work until they reconnect to the VPN and run through the compliance check.

I did poke around in our endpoint compliance policy but didn't see anything obvious that would cause the compliance check to revert that change and force https.

Long story short, we want our developers, when connected to Checkpoint VPN, to be able to access http on localhost without https redirection. Is this possible? If so, what do I need to do?

Thanks in advance and sorry again if I posted this in the wrong area, didn't include any necessary or useful information, etc. 

0 Kudos
1 Reply
Chris_Atkinson
Employee
Employee

For clarity you've implemented something that disables the following setting in the browser (chrome) or similar and you see it toggled back on again?

Browser.png

 

 

0 Kudos