I rolled out a new Skyline config to a bunch of systems recently, and several didn't actually start sending telemetry. Troubleshooting them today, and thought I would share information which seems to be missing from the guides and SKs.
On the first one, I found /opt/CPotelcol/otelcol.log was about 40 MB and had last been written in March. I tried manually stopping and starting CPotelcol using '/opt/CPotelcol/stop' and '/opt/CPotelcol/start'. Still no log data.
I rotated the log file manually using the command 'mv /opt/CPotelcol/otelcol.log{,.2026-03-04}' and ran '/opt/CPotelcol/start'. Still no telemetry, but at least I got log data! A tail of the log shows the message {"kind": "extension", "name": "health_check", "error": "failed to bind to address 127.0.0.1:65533: listen tcp 127.0.0.1:65533: bind: address already in use"}.
Okay, why can't it bind to the port? Most likely cause is something else listening. Ran 'netstat -anp | grep 65533' and sure enough fwd was already listening on that port. This particular system happens to be an MDS, so I got the PID and used 'ps -fp <PID>' to find which CMA owned that fwd. I restarted it ('mdsstop_customer <CMA name> && mdsstart_customer <CMA name>'), then ran '/opt/CPotelcol/start' again. This time, it started, and my telemetry destination started receiving data.
Looks like port 65533 is hard-coded in $CPOTELCOL_DIR/config.json, but other things can get there first. If Skyline is just mysteriously not working for you, check to be sure nothing else has grabbed the port.