Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
John_Fleming
Advisor

R80.40 MDS JH 91 - Legacy Server IP validation error

Has anyone seen an issue with JH91 where after logging into the MDS database you get an error in the validation window saying

Legacy Server IP

CMA_IP is already in used by CMA_NAME.

At: (unnamed)

 

Where CMA_IP is a valid CMA IP that matches CMA_NAME? Clicking unnamed brings up an object editor on a blank object that seems to have no type. You can change the name but you can't put a IP or anything else in it. Its just not there. I'm kind of thinking this is like null object issue. There is one for each CMA. The MDS IP does not show up.

This is all inside a lab. We were almost ready to go production but found a bug where the API would return 400 on show packages calls made directly to a CMA that housed SMB policies (Gaia Embedded - Your stomach acid levels are way too low, setting to %250). We rebuilt with 91 and post advanced import (same export used for take 87) we now these strange database errors.

We have a ticket open but we're not sure we're going to stick at 91 and trouble shoot this as the warm fuzzies are not there. I'm about to run cpm dr.

0 Kudos
Reply
5 Replies
PhoneBoy
Admin
Admin

Yeah that looks like database corruption somewhere.
Least that’s what it feels like.

0 Kudos
Reply
John_Fleming
Advisor

My whining skills are getting rusty. I couldn't get CFG on the phone day one. Hopefully something next week. We're basically going back to 87 and will spin a VM with 91 to continue trouble shooting. Most likely will start asking for one off patches monday.

0 Kudos
Reply
Kaspars_Zibarts
Authority
Authority

Hi John - I just installed Take 91 in the lab on our MDS and all looks good, no validation errors. Looks like some specific issue with your environment

0 Kudos
Reply
John_Fleming
Advisor

Oh man, thanks for checking that out. I feel better about my install. Mine is a special case. Upgrading from R77.30 -> R80.40 JH91 via advanced upgrade.

After trouble shooting session CFG discovered running solr_cur.sh -j, mdsstop, deleting the solr database and mdsstart the validation error went away. They think its something with the upgrade process that isn't working right so that is most likely why i'm seeing this and you aren't. 

0 Kudos
Reply
John_Fleming
Advisor

Just a FYI we rebuilt everything from scratch and doing the 4 steps above addressed the validation error.

0 Kudos
Reply