Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Is Packet Injector supported in R80.20?

R80.20 is not mentioned on sk110865 as one of the versions that support the Packet Injector Tool. Does the documentation need to be updated or the said tool is not supported on R80.20 at the moment? If so, how long it will be before it does?

Thanks in advance.

6 Replies
Highlighted

In the SK it says on the download link: (TGZ) v1.4.6 for R80.x
That would indicate it should work, however:
[Expert@CPFW-01:0]# ./pinj --help
Traceback (most recent call last):
File "main.py", line 11, in <module>
import generator
File "/opt/CPPinj-R80/scripts/generator.py", line 15, in <module>
from scapy.all import *
File "/opt/CPPinj-R80/scripts/packetmaker.zip/scapy/all.py", line 28, in <module>
File "/opt/CPPinj-R80/scripts/packetmaker.zip/scapy/route6.py", line 271, in <module>
File "/opt/CPPinj-R80/scripts/packetmaker.zip/scapy/route6.py", line 29, in __init__
File "/opt/CPPinj-R80/scripts/packetmaker.zip/scapy/route6.py", line 42, in resync
File "/opt/CPPinj-R80/scripts/packetmaker.zip/scapy/arch/linux.py", line 245, in read_routes6
IOError: [Errno 12] Cannot allocate memory
Regards, Maarten
Highlighted

So the short answer is probably no...
0 Kudos
Highlighted

Indeed, my answer would be: No it is not working and therefore not supported (yet).
Regards, Maarten
Highlighted

Thanks for having a look anyway!
0 Kudos
Highlighted

Hi @Nick_Doropoulos 

Packet Injector is not supported on R80.20 only for R77, R77.10, R77.20, R77.30, R80.10.

Tags (1)
Highlighted

More see here sk 110865:

Check Point Packet Injector

Tags (1)
0 Kudos