Create a Post
cancel
Showing results for 
Search instead for 
Did you mean: 
Felix_Hoffmann1
Participant

searching an object by ipv6 not working

Jump to solution

Hey,

I am using web-services to search for objects by IP. That is working fine when I'm searching for an IPv4-address. But searching an IPv6-address does not work. Am I calling something wrong?

IPv4-call:

IPv6-call:

>>> result = api_call('show-objects', {'filter':'2001:and-so-on::38','ip-only':'true'}, sid, mgmtserv, mgmtport)

shows a total of 8988 results... Even when searching a string that definitely does not exist, it shows this amount of results.

any help would be appreciated

thanks in advance

Felix

Labels (1)
1 Solution

Accepted Solutions
Robert_Decker
Employee Alumnus
Employee Alumnus

Hi Felix,

For IPv6 address search do NOT use the "ip-only" flag. We will fix the API references.

Robert.

View solution in original post

3 Replies
Robert_Decker
Employee Alumnus
Employee Alumnus

Check this filter in SmartConsole to ensure the results. The filter in API should be identical to the filter in GUI.

Robert.

0 Kudos
Reply
Felix_Hoffmann1
Participant

Hi, thank you for your answer. When filtering in SmartConsole I find the object. When using SmartConsoleCLI the problem is the same

But:

when using the filter without "ip-only:true" the object is shown. Does ip-only just search ip4v-addresses?

If this is the case could you please add this as comment to the management API Reference?

Felix

0 Kudos
Reply
Robert_Decker
Employee Alumnus
Employee Alumnus

Hi Felix,

For IPv6 address search do NOT use the "ip-only" flag. We will fix the API references.

Robert.

View solution in original post