Create a Post
Showing results for 
Search instead for 
Did you mean: 
Not applicable

CPdeploy Container Available

I have been working on command line deployments of aws and azure, that include the network and application for a full app stack test. It is very rudimentary, but what I have discovered it, its an easy way to edit some variables, then launch configurations, networks, objects, gateways, apps, etc, in varying combinations to see first hand what works, and what doesn't.  Not sure if you have network connectivity between two VPC or subnets? Don't wonder, spin them up and test for yourself. I even have simulated clients in the script, but be careful with them, they can get aggressive if launched from a decent sized ami. They will consume the web app at a ferocious rate. 4 or 5 clients running on 16 core machines can consume over 100,000 concurrent connections, and sustain 10k+ connections/sec setup rate. If you aren't seeing that high a transaction rate, try running up the application as well as the gateway, or spread the traffic across multiple sites. I don't have elb configuration in this, yet, but DNS is configured, and if you have played with DNS in aws, it's not really DNS, its a programmatic change to the enviroment. My hosted value for DNS is in there now, not that you can do anything with it, you will need to set that to use DNS injection, otherwise ignore the dns errors, it just means there is no injection for name to IP. Everything will still work based on IP.

Azure is also incorporated, but the app needs to be manually installed, just time on my part. I will be putting together real training and documentation around using this, but for now, wanted to share this as it is live. For those of you that tried and say cpdeploy, the shell script, here is the container version, environment all set with the tools you need. Edit /cpdeploy/VAR, or type 'cpconfig' to set variables. To load the latest container on any docker host capable of running docker containers;

docker run --name cpdeploy -i -t kellman/cpdeploy

that will pull the latest container and drop you in a shell to try for yourself. Your milage will vary. This will continue to evolve and expand, and I will use this location to update the progress. With this container, I am killing all work on the original shell script. It is still online, but will not be updated. Please use the container for future versions. Big thanks to Lon for his curl based R80api calls, makes this much easier to transport, nice work Lon Kaut​ .

4 Replies
Not applicable

Here is the docker hub page for the container.

0 Kudos
Not applicable

Ugh. In my effort to keep the container small, i broke the azure portion. Just pushed a new container, azure binary is fixed, but the size just jumped.

0 Kudos
Not applicable

Nice Work Kellman! 

Brilliant idea.

Pulling this down today on my coreos box.

0 Kudos
Not applicable

Just a note that I have done some big overhauls on the cpdeploy, still a container, but in the process introduced some bad bugs. Should be all clean now, just finished testing from clean install to finish. Sorry if you have tried it in the last couple of days, in an effort tot make it smaller, I broke a few things. Should be all ok now.

The container can be pulled directly from here:

And there is now some documentation that will help you get from zero to gateways in the sky here:

just follow the link to the CPdeploy document on the front page.

0 Kudos


Epsum factorial non deposit quid pro quo hic escorol.

Upcoming Events

    CheckMates Events