Create a Post
Showing results for 
Search instead for 
Did you mean: 

API - using script on domain/cma which is on an MDS

What I want:

Execute API commnand install-policy by a script stored in script repository. The domain is on an MDS.

I have already realized the script button in menu point only to the gateways.

What I have tried:

1.    Execute the command via the "comand line" tab/window. This works fine.

2.    Execute the the command by right-click on the CMA -> Scripts -> One time Script.... in the way:

mgmt_cli install-policy (with params tested before in command line window)

It first seems to start well, but finally it runs into an error:

"Connection failed for "IP-Address". Make sure that the machine is up and running, and that SIC has been established"

As menitoned execution in comand line window works. As well a usual install policy by GUI.

What did I overlook?

5 Replies

I'm pretty sure that run-script (the underlying API used in this case) does not work when an MDS/CMA is the target.

Have you tried other scripts by chance and do they work?

Amiad Stern

0 Kudos

Run script is not supported on domains / MDS. you can see in UI it is only available for objects listed in 'Gateways & Servers' view 

0 Kudos

Not 100% correct. I you right-click on the object of the CMA you find the script option and it will be finally executed on CMA. BUT it does not get the right context.
So I would propose to add a script repository option to the API CLi window. The primary problem is, the "Open File" button opens a folder in user context. So it is very difficult to share scripts.


Hi Andreas Lorenzen, I'm not sure I got to the bottom of your proposal and the issue with the open file, i would be happy to keep this conversation off-line by mail.

Please send me exact issue and your proposal by mail to (screenshots would be helpful)



0 Kudos

will do


Epsum factorial non deposit quid pro quo hic escorol.

Upcoming Events

    CheckMates Events